[mythtv-users] Re: anyone attempt mythfrontend on Cygwin?

Mario L superm1 at gmail.com
Thu Sep 23 21:41:16 EDT 2004


Once i got QT (X11) up and running, I installed DirectX for cygwin,
and downloaded myth CVS.  There is a problem downloading from CVS,
windows doesnt seem to appreciate the name "G.A.N.T."   Too many
periods would be my guess, but I don't know.  I downloaded CVS source
from a real.... er i mean, linux machine and renamed that directory
and copied over.

To get the compilation to Start working, 
1) Disabled IVTV 
2) Disabled x11 ( there is no xinerama support i believe for libmythtv )
3) enabled win32
4) enabled directx
all under settings.pro

Libavcodec seems to compile fine, and like joel had run into,
libavformat doesn't seem to compile.  I made a few changes to
libavformat.pro:

FROM:
------------
        LIBS += -L../libavcodec -lmythavcodec-$$LIBVERSION
------------
TO:
-----------
!win32{
        LIBS += -L../libavcodec -lmythavcodec-$$LIBVERSION
}

win32{
        LIBS += -L../libavcodec -l
../libavcodec/cygmythavcodec-$${LIBVERSION}-0.dll.a
}
-----------

I still got compiling problems:
-------------------------------------------------------------------------------------------------------------
Mario Limonciello at supermario /tmp/mythtv/libs/libavformat
$ make
test -d  || mkdir -p 
rm -f cygmythavformat-0.16-0.dll libmythavformat-0.16.a
libmythavformat-0.16.dll.a
g++ -Wl,--enable-runtime-pseudo-reloc -shared
-Wl,-soname,cygmythavformat-0.16-0.dll -o cygmythavformat-0.16-0.dll
4xm.o allformats.o asf.o au.o avidec.o avienc.o avio.o aviobuf.o crc.o
cutils.o dv.o ffm.o file.o flvdec.o flvenc.o idcin.o idroq.o img.o
ipmovie.o mov.o movenc.o mp3.o mpeg.o mpegts.o mpegtsenc.o mpjpeg.o
nut.o os_support.o rm.o psxstr.o raw.o flic.o audio.o segafilm.o swf.o
utils.o wav.o wc3movie.o westwood.o yuv4mpeg.o sierravmd.o asf-enc.o
matroska.o img2.o   -L/opt/qt/3.2/qt-x11-free-3.2.3/lib
-L/usr/X11R6/lib -L../libavcodec -l
../libavcodec/cygmythavcodec-0.16-0.dll.a -lqt-mt -lXext -lX11
-lpthread
/usr/lib/gcc-lib/i686-pc-cygwin/3.3.3/../../../../i686-pc-cygwin/bin/ld:
cannot find -l../libavcodec/cygmythavcodec-0.16-0.dll.a
collect2: ld returned 1 exit status
make: *** [cygmythavformat-0.16-0.dll] Error 1
------------------------------------------------------------------------------------------------------------

Even though it is quite clear that the file does exist:
------------------------------------------------
$ ls ../libavcodec/ -alh | grep cyg
-rwxr-xr-x    1 Mario Li None         5.7M Sep 23 19:52
cygmythavcodec-0.16-0.dll
lrwxrwxrwx    1 Mario Li None           32 Sep 23 19:52
libmythavcodec-0.16.dll.a -> ../bin/cygmythavcodec-0.16-0.dll
-----------------------------------------------

I might have to jump back to just regualr myth .16 source and see if
that helps at all.


More information about the mythtv-users mailing list