[mythtv-users] Problems filling database

Pascal Hos pascalhos at gmail.com
Sun Sep 26 07:00:01 EDT 2004


Thanks for replying. I thought I was the only one stuck with this
problem. No I have not resolved this problem. When you say "I ran
mythbackend and told it to wip out my channel database" do you mean
you ran mythtvsetup and answered yes to clear channel data?


On Sat, 25 Sep 2004 14:28:06 -0400, Bryce Tennant <btek at rochester.rr.com> wrote:
> Did you get this issue resolved? I was seeing the same issue and I rebuilt my
> channel database which seems to have fixed the problem. I ran mythbackend and
> told it to wip out my channel database. Once that was complete I reran
> mythfilldatabase. Everything appears to work now.
> 
> 
> 
> 
> On Tuesday 21 September 2004 02:37 am, Pascal Hos wrote:
> > I have just set up a FC2 system based on Jarod's guide (Thanks for
> > that!). I now have a problem which I see other have as well but I have
> > not seen a solution.
> >
> > I am not able to fill the database with listings. I get the
> > following output when running mythfilldatabase --manual:
> >
> > ### New channel found
> > ###
> > ### name = Nederland 1
> > ### callsign =
> > ### channum =
> > ### finetune =
> > ### tvformat =
> > ### icon = /home/mythtv/.mythtv/channels/ned1.png
> > ###
> > Choose a channel ID (positive integer) [0] 1
> > Choose a channel name (any string, long version) [Nederland 1]
> > Choose a channel callsign (any string, short version) ned1
> > Choose a channel number (just like xawtv) E9
> > Choose a channel fine tune offset (just like xawtv)
> > Choose a TV format (PAL/SECAM/NTSC/ATSC/Default)
> > Choose a channel icon image (any path name)
> > [http://xmltv.fambus.nl/logos/ned1.png]
> > Query was:
> > SELECT chanid,name,callsign,channum,finetune,icon,freqid,tvformat FROM
> > channel WHERE xmltvid = "1.tvgids.nl" AND sourceid = 1;
> > No error type from QSqlError? Strange...
> >
> > This happens for every channel. Then after entering all the info I get
> > the following:
> >
> > Unknown xmltv channel identifier: 1.tvgids.nl
> > Skipping channel.
> > Adjusting program database end times...
> > 0 replacements made.
> >
> > When running mythfrontend I keep seeing the following error:
> > QDateTime::fromString: Parameter out of range
> >
> > and another clear sign that something is wrong:
> > metadata.o: Your database is out of whack. This is not good.
> >
> > And when trying to run mythmusic I get the following:
> > QObject::connect: No such slot
> > PlaybackBox::handleTreeListSignals(int,IntVector*)
> > QObject::connect: (sender name: 'musictreelist')
> > QObject::connect: (receiver name: 'music_playback')
> > QObject::connect: No such slot PlaybackBox::previous()
> > QObject::connect: (sender name: 'prev_button')
> > QObject::connect: (receiver name: 'music_playback')
> > ..................
> >
> > I am not familiar enough with MySQL to start playing around with it
> > myself. Is there anyone who was having these problems and has now
> > solved it?
>


More information about the mythtv-users mailing list