[mythtv-users] Problems filling database

Albert Ulmer jayaeu at gmail.com
Thu Sep 30 07:23:09 EDT 2004


On Thu, 30 Sep 2004 12:59:47 +0200, Pascal Hos <pascalhos at gmail.com> wrote:
> Well, I managed to get it work.
> I defined my channels manually in myth-setup with the appropriate
> xmltv id assigned. After that I could run mythfilldatabase and it
> populated the program guide without a problem.
> If you run your tv_grab_* and have it output to a file it will tell
> you what the xmltv id is you have to use.
> 
> Pascal
> 
This is very good advice. I've been struggling with my old analogue
WinTV from 1997 trying to sync channels and EPG in the channel setup.
Putting the ID in solved the problem! Thanks!
> 
> On Wed, 29 Sep 2004 18:16:26 -0400, Bryce Tennant <btek at rochester.rr.com> wrote:
> > Pascal,
> > Good luck to you, thanks for the feedback.
> > Bryce
> >
> >
> >
> > On Sunday 26 September 2004 10:12 am, Pascal Hos wrote:
> > > Bryce,
> > >
> > > That did not work for me. I keep getting the same problem. I have
> > > tried on a few different distributions thinking it might have
> > > something to do with the way some dists set up mysql but I got the
> > > same problem on all of them.
> > > I do have it working on my system which run PCLinuxOS, but I think
> > > that is because I installed version  0.15 first and then upgraded
> > > later on.
> > > Anyway, I hope you figure it out. I would really like to set up my
> > > system from scratch.
> > >
> > > Pascal
> > >
> > > On Sun, 26 Sep 2004 09:12:07 -0400, Bryce Tennant <btek at rochester.rr.com>
> > wrote:
> > > > OK I was able to get it working again. I did the following
> > > > 1> Ran mythsetup and cleared the channel database
> > > > 2> reran mythfilldatabase
> > > > 3> Restarted mythbackend ( This was the step I was missing before )
> > > > 4> Ran the mythfrontend.
> > > >
> > > > I can now change channels. I am going to reboot the computer and see if
> > > > it still has the problem when I come up again. I hope that it has will go
> > > > away now but I am not convinced. I think I will shutdown mythbackend
> > > > before I reboot. I have no good evidence that this is a problem but I
> > > > want things to stop somewhat gracefully.
> 
> 
> > > >
> > > > On Sunday 26 September 2004 07:00 am, Pascal Hos wrote:
> > > > > Thanks for replying. I thought I was the only one stuck with this
> > > > > problem. No I have not resolved this problem. When you say "I ran
> > > > > mythbackend and told it to wip out my channel database" do you mean
> > > > > you ran mythtvsetup and answered yes to clear channel data?
> > > > >
> > > > > On Sat, 25 Sep 2004 14:28:06 -0400, Bryce Tennant
> > > > > <btek at rochester.rr.com>
> > > >
> > > > wrote:
> > > > > > Did you get this issue resolved? I was seeing the same issue and I
> > > > > > rebuilt my channel database which seems to have fixed the problem. I
> > > > > > ran mythbackend and told it to wip out my channel database. Once that
> > > > > > was complete I reran mythfilldatabase. Everything appears to work
> > > > > > now.
> > > > > >
> > > > > > On Tuesday 21 September 2004 02:37 am, Pascal Hos wrote:
> > > > > > > I have just set up a FC2 system based on Jarod's guide (Thanks for
> > > > > > > that!). I now have a problem which I see other have as well but I
> > > > > > > have not seen a solution.
> > > > > > >
> > > > > > > I am not able to fill the database with listings. I get the
> > > > > > > following output when running mythfilldatabase --manual:
> > > > > > >
> > > > > > > ### New channel found
> > > > > > > ###
> > > > > > > ### name = Nederland 1
> > > > > > > ### callsign =
> > > > > > > ### channum =
> > > > > > > ### finetune =
> > > > > > > ### tvformat =
> > > > > > > ### icon = /home/mythtv/.mythtv/channels/ned1.png
> > > > > > > ###
> > > > > > > Choose a channel ID (positive integer) [0] 1
> > > > > > > Choose a channel name (any string, long version) [Nederland 1]
> > > > > > > Choose a channel callsign (any string, short version) ned1
> > > > > > > Choose a channel number (just like xawtv) E9
> > > > > > > Choose a channel fine tune offset (just like xawtv)
> > > > > > > Choose a TV format (PAL/SECAM/NTSC/ATSC/Default)
> > > > > > > Choose a channel icon image (any path name)
> > > > > > > [http://xmltv.fambus.nl/logos/ned1.png]
> > > > > > > Query was:
> > > > > > > SELECT chanid,name,callsign,channum,finetune,icon,freqid,tvformat
> > > > > > > FROM channel WHERE xmltvid = "1.tvgids.nl" AND sourceid = 1;
> > > > > > > No error type from QSqlError? Strange...
> > > > > > >
> > > > > > > This happens for every channel. Then after entering all the info I
> > > > > > > get the following:
> > > > > > >
> > > > > > > Unknown xmltv channel identifier: 1.tvgids.nl
> > > > > > > Skipping channel.
> > > > > > > Adjusting program database end times...
> > > > > > > 0 replacements made.
> > > > > > >
> > > > > > > When running mythfrontend I keep seeing the following error:
> > > > > > > QDateTime::fromString: Parameter out of range
> > > > > > >
> > > > > > > and another clear sign that something is wrong:
> > > > > > > metadata.o: Your database is out of whack. This is not good.
> > > > > > >
> > > > > > > And when trying to run mythmusic I get the following:
> > > > > > > QObject::connect: No such slot
> > > > > > > PlaybackBox::handleTreeListSignals(int,IntVector*)
> > > > > > > QObject::connect: (sender name: 'musictreelist')
> > > > > > > QObject::connect: (receiver name: 'music_playback')
> > > > > > > QObject::connect: No such slot PlaybackBox::previous()
> > > > > > > QObject::connect: (sender name: 'prev_button')
> > > > > > > QObject::connect: (receiver name: 'music_playback')
> > > > > > > ..................
> > > > > > >
> > > > > > > I am not familiar enough with MySQL to start playing around with it
> > > > > > > myself. Is there anyone who was having these problems and has now
> > > > > > > solved it?
> >
> 
> 
> 
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> 
> 
>


More information about the mythtv-users mailing list