[mythtv-users] How do you "tune" subchannels in QAM?

John Patrick Poet john at BlueSkyTours.com
Fri Apr 1 00:26:02 UTC 2005


Since you can view them outside of Myth, your channels must not be
encrypted.  Unfortunately for me, most of mine are.

When I went through that process, it LOCKED a whole bunch of channels, but
only was able to TUNE the three unencrypted channels which my local Comcast
system provides.  Since those three are a subset of what I can get
over-the-air, I aborted using QAM and went back to using my antenna.

Also, I am told that my local Comcast cable uses equipment to compress down
the ATSC mpeg2 streams on-the-fly, so they can fit more channels in the same
bandwidth.  I therefore should be getting a "better" picture over-the-air.

I assume you want to use QAM to get channels which are not available
over-the-air?

I certainly can't complain about the over-the-air picture quality from my
HD-3000 cards.  I recently added a PVR-350 to my system, and it works fine,
but the picture quality compared to HD is almost painful.

Re-reading my message here, I realize it really does not help you.  Sorry.

John

On Thu, 31 Mar 2005, Adam Gianola wrote:

> I can't figure out what is wrong because channel scanning doesn't seem
> to work at all.  At least not for me... and it sounds like others are
> also having the exact same problem.  Azap works and tunes fine and
> captures work outside of mythtv using dvbstream.  I have viewed them
> lots of times on several channels, it is fantastic to see HD captures
> from digital cable :)
>
> Mythtv, however, is not working with the hd3000-dvb & qam (or at least
> hasn't been) for me.  It seems when scanning channels in mythtvsetup,
> something is off, as the frequencies which lock are not added to the
> database in any useable way.  I only get 'timeout tuning channel' or
> 'unable to tune channel' or something like this.  I thought maybe
> database entries should be added to the tables 'dvb_channel' or
> 'dvb_pids' or 'channel' but the only thing i've been able to get are
> entries to 'dtv_multiplex' after scanning which help (so I may
> manually edit the db) but don't give any functionality.  I haven't
> been able to view programs yet with the above method of manually
> editing the database (away from the frontend), but i'm certainly
> stumped otherwise and am not afraid to try this.
>
> As i may have mentioned before, for me no channel information seems to
> come through with the TS which may be why myth is hanging here.  I
> think that 'dvbscan -cvvv' after azap cxxx is where i would see this
> (outside of myth) but don't.  Perhaps your cable system is providing
> this kind of information which is why you can get mythtv to autoscan.
> Then again, maybe there's something else I'm missing...  If you can
> think of anything, I'm ready to try anything... even went so far as to
> install myth from cvs (reverted back to atrpms though), to see if
> something new was changed since the last release.
>
> Cheers,
> Adam
>
>
>
>
> On Thu, 31 Mar 2005 15:25:23 -0800, John Sturgeon
> <mythtv at sturgeonfamily.com> wrote:
> > Marc Tousignant wrote:
> >
> > > I think I figured it out?
> > >
> > > Since I knew C82 program 1 was my local PBS I located the correct
> > > frequency for this channel in dtv_multiplex
> > >
> > > INSERT INTO dtv_multiplex (mplexid, sourceid, transportid, networkid,
> > > frequency, inversion, symbolrate, fec, polarity, modulation,
> > > bandwidth, lp_code_rate, transmission_mode, guard_interval, visible,
> > > constellation, hierarchy, hp_code_rate, sistandard, serviceversion,
> > > updatetimestamp) VALUES
> > > (89,1,NULL,NULL,573000000,'a',NULL,'auto',NULL,'qam_256','a','auto','a','auto',0,'auto','auto','auto','atsc',33,20050331082612);
> > >
> > > Using this knowledge I then changed the mplexid of the correct listing
> > > to 89 in channel.
> > >
> > > INSERT INTO channel (chanid, channum, freqid, sourceid, callsign,
> > > name, icon, finetune, videofilters, xmltvid, recpriority, contrast,
> > > brightness, colour, hue, tvformat, commfree, visible, outputfilters,
> > > useonairguide, mplexid, serviceid, atscsrcid) VALUES
> > > (1802,'802','802',1,'WGBHDT','WGBHDT
> > > (WGBH-DT)','none',NULL,'','28055',0,32768,32768,32768,32768,'Default',0,1,'',0,89,NULL,NULL);
> > >
> > > Starting mythbackend I then saw
> > >
> > > 2005-03-31 13:55:09.792 SIParser: About to do a reset
> > >
> > > 2005-03-31 13:55:09.792 SIParser: Closing all PIDs
> > >
> > > 2005-03-31 13:55:09.792 SIParser: Using DelAllPids from SIParser which
> > > does nothing
> > >
> > > 2005-03-31 13:55:09.792 SIParser: Resetting all Table Handlers
> > >
> > > 2005-03-31 13:55:09.792 SIParser: SIParser Reset due to channel change
> > >
> > > 2005-03-31 13:55:09.793 DVB#0 DVB SI Table Parser Started
> > >
> > > 2005-03-31 13:55:09.793 DVB#0 Using DVB card 0, with frontend pcHDTV
> > > HD3000 HDTV.
> > >
> > > 2005-03-31 13:55:09.793 DVB#0 Trying to tune to channel 802.
> > >
> > > 2005-03-31 13:55:09.793 SIParser: Starting DVB Section Reader thread
> > >
> > > 2005-03-31 13:55:09.793 SIParser: Starting SIScanner
> > >
> > > 2005-03-31 13:55:09.794 DVB#0 Mod:
> > >
> > > 2005-03-31 13:55:09.794 SIParser: About to do a reset
> > >
> > > 2005-03-31 13:55:09.794 SIParser: Closing all PIDs
> > >
> > > 2005-03-31 13:55:09.795 SIParser: Resetting all Table Handlers
> > >
> > > 2005-03-31 13:55:09.795 SIParser: SIParser Reset due to channel change
> > >
> > > 2005-03-31 13:55:09.795 DVB#0 Waiting for frontend event after tune.
> > >
> > > 2005-03-31 13:55:10.055 DVB#0 DVB signal 977 | snr fde1 | ber 0 | unc 0
> > >
> > > 2005-03-31 13:55:10.055 DVB#0 Status: LOCK.
> > >
> > > 2005-03-31 13:55:10.055 SIParser: Requesting PAT
> > >
> > > 2005-03-31 13:55:10.055 DVB#0 Multiplex Locked
> > >
> > > 2005-03-31 13:55:10.055 SIParser: Adding a PMT (0) to the request list
> > >
> > > 2005-03-31 13:55:10.796 SIParser: Table[0]->RequirePIDs() == true
> > >
> > > 2005-03-31 13:55:10.797 SIParser: Adding PID 0 Filter 0 Mask ff Buffer
> > > 40960
> > >
> > > 2005-03-31 13:55:10.797 SIParser: Table[2]->RequirePIDs() == true
> > >
> > > 2005-03-31 13:55:10.797 SIParser: Adding PID 1ffb Filter ff Mask 0
> > > Buffer 40960
> > >
> > > 2005-03-31 13:55:10.798 SIParser: Table[3]->RequirePIDs() == true
> > >
> > > 2005-03-31 13:55:10.798 SIParser: Adding PID 1ffb Filter ff Mask 0
> > > Buffer 40960
> > >
> > > 2005-03-31 13:55:11.150 SIParser: PAT Version = 2
> > >
> > > 2005-03-31 13:55:11.150 SIParser: Tuned to TransportID: 32950
> > >
> > > 2005-03-31 13:55:11.150 SIParser: Services on this Transport: 1 2
> > >
> > > 2005-03-31 13:55:11.150 SIParser: Table[0]->Complete() == true
> > >
> > > 2005-03-31 13:55:11.150 SIParser: Table[1]->RequirePIDs() == true
> > >
> > > 2005-03-31 13:55:11.150 SIParser: Adding PID 0 Filter 2 Mask ff Buffer
> > > 40960
> > >
> > > 2005-03-31 13:55:16.059 DVB#0 Timeout Getting PMT
> > >
> > > 2005-03-31 13:55:16.059 DVB#0 ERROR - Tuning for channel #802 failed.
> > >
> > > Taking a guess I then went back and changed the serviceid to 1 because
> > > it was subchannel 1
> > >
> > > INSERT INTO channel (chanid, channum, freqid, sourceid, callsign,
> > > name, icon, finetune, videofilters, xmltvid, recpriority, contrast,
> > > brightness, colour, hue, tvformat, commfree, visible, outputfilters,
> > > useonairguide, mplexid, serviceid, atscsrcid) VALUES
> > > (1802,'802','802',1,'WGBHDT','WGBHDT
> > > (WGBH-DT)','none',NULL,'','28055',0,32768,32768,32768,32768,'Default',0,1,'',0,89,1,NULL);
> > >
> > > Now I am getting this in mythbackend on start
> > >
> > > 2005-03-31 13:59:22.477 SIParser: About to do a reset
> > >
> > > 2005-03-31 13:59:22.477 SIParser: Closing all PIDs
> > >
> > > 2005-03-31 13:59:22.477 SIParser: Using DelAllPids from SIParser which
> > > does nothing
> > >
> > > 2005-03-31 13:59:22.477 SIParser: Resetting all Table Handlers
> > >
> > > 2005-03-31 13:59:22.477 SIParser: SIParser Reset due to channel change
> > >
> > > 2005-03-31 13:59:22.478 DVB#0 DVB SI Table Parser Started
> > >
> > > 2005-03-31 13:59:22.478 SIParser: Starting DVB Section Reader thread
> > >
> > > 2005-03-31 13:59:22.478 DVB#0 Using DVB card 0, with frontend pcHDTV
> > > HD3000 HDTV.
> > >
> > > 2005-03-31 13:59:22.478 DVB#0 Trying to tune to channel 802.
> > >
> > > 2005-03-31 13:59:22.478 SIParser: Starting SIScanner
> > >
> > > 2005-03-31 13:59:22.479 DVB#0 Mod:
> > >
> > > 2005-03-31 13:59:22.479 SIParser: About to do a reset
> > >
> > > 2005-03-31 13:59:22.480 SIParser: Closing all PIDs
> > >
> > > 2005-03-31 13:59:22.480 SIParser: Resetting all Table Handlers
> > >
> > > 2005-03-31 13:59:22.480 SIParser: SIParser Reset due to channel change
> > >
> > > 2005-03-31 13:59:22.480 DVB#0 Waiting for frontend event after tune.
> > >
> > > 2005-03-31 13:59:22.740 DVB#0 DVB signal 977 | snr fdc9 | ber 0 | unc 0
> > >
> > > 2005-03-31 13:59:22.740 DVB#0 Status: LOCK.
> > >
> > > 2005-03-31 13:59:22.740 SIParser: Requesting PAT
> > >
> > > 2005-03-31 13:59:22.740 DVB#0 Multiplex Locked
> > >
> > > 2005-03-31 13:59:22.740 SIParser: Adding a PMT (1) to the request list
> > >
> > > 2005-03-31 13:59:23.481 SIParser: Table[0]->RequirePIDs() == true
> > >
> > > 2005-03-31 13:59:23.481 SIParser: Adding PID 0 Filter 0 Mask ff Buffer
> > > 40960
> > >
> > > 2005-03-31 13:59:23.482 SIParser: Table[2]->RequirePIDs() == true
> > >
> > > 2005-03-31 13:59:23.482 SIParser: Adding PID 1ffb Filter ff Mask 0
> > > Buffer 40960
> > >
> > > 2005-03-31 13:59:23.483 SIParser: Table[3]->RequirePIDs() == true
> > >
> > > 2005-03-31 13:59:23.483 SIParser: Adding PID 1ffb Filter ff Mask 0
> > > Buffer 40960
> > >
> > > 2005-03-31 13:59:23.899 SIParser: PAT Version = 2
> > >
> > > 2005-03-31 13:59:23.900 SIParser: Tuned to TransportID: 32950
> > >
> > > 2005-03-31 13:59:23.900 SIParser: Services on this Transport: 1 2
> > >
> > > 2005-03-31 13:59:23.900 SIParser: Table[0]->Complete() == true
> > >
> > > 2005-03-31 13:59:23.900 SIParser: Table[1]->RequirePIDs() == true
> > >
> > > 2005-03-31 13:59:23.900 SIParser: Adding PID 30 Filter 2 Mask ff
> > > Buffer 40960
> > >
> > > 2005-03-31 13:59:24.121 SIParser: PMT ServiceID: 1 Version = 4
> > >
> > > 2005-03-31 13:59:24.121 SIParser: PID: 2048
> > >
> > > 2005-03-31 13:59:24.121 SIParser: Unknown descriptor, tag = 6
> > >
> > > 2005-03-31 13:59:24.121 SIParser: Unknown descriptor, tag = 134
> > >
> > > 2005-03-31 13:59:24.121 SIParser: PID: 2049
> > >
> > > 2005-03-31 13:59:24.121 SIParser: Unknown descriptor, tag = 129
> > >
> > > 2005-03-31 13:59:24.122 SIParser: PID: 2050
> > >
> > > 2005-03-31 13:59:24.122 SIParser: Unknown descriptor, tag = 129
> > >
> > > 2005-03-31 13:59:24.122 SIParser: Table[1]->EmitRequired() == true
> > >
> > > 2005-03-31 13:59:24.122 DVB#0 Successfully tuned to channel 802.
> > >
> > > I am not sure if this is really working as I am not at home to try it.
> > > Was playing with it during my lunch break and wont be able to try till
> > > I get home.
> > >
> > > My hopes are high that I am on the right track thou.
> > >
> > >>I think quite a few of us working with the hd3000 are having the same
> > >
> > >>problem and are looking for solutions. I've posted both here and in
> > >
> > >>the hd3000 forum but it seems like no one has been able to find a
> > >
> > >>solution to this problem yet. I haven't posted to myth-dev yet, but
> > >
> > >>maybe thats the place where we may find someone who knows the answer
> > >
> > >>to our question, as i think it is a problem with how mythtvsetup is
> > >
> > >>handling the hd3000-dvb. For example, when i run dvbscan -cvvv no
> > >
> > >>channel information is given, but i've seen examples with OTA ATSC
> > >
> > >>streams where channel information is explicitly supplied in the
> > >
> > >>stream. Mythtv may be looking for this and since it doesn't come
> > >
> > >>through, myth assumes the channels are 'unable to tune'.
> > >
> > >>
> > >
> > >>-Adam
> > >
> > >>
> > >
> > >>
> > >
> > >>
> > >
> > >>for reference:
> > >
> > >>http://www.xmission.com/~pchdtv/forum/viewtopic.php?t=639
> > >
> > >>http://www.xmission.com/~pchdtv/forum/viewtopic.php?t=634
> > >
> > >>http://www.gossamer-threads.com/lists/mythtv/users/121772
> > >
> > >>http://www.gossamer-threads.com/lists/mythtv/users/120911
> > >
> > >>http://www.linuxtv.org/wiki/index.php/PcHDTV
> > >
> > >------------------------------------------------------------------------
> > >
> > >_______________________________________________
> > >mythtv-users mailing list
> > >mythtv-users at mythtv.org
> > >http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> > >
> > >
> > AACK!
> >
> > You shouldn't have to do this! Please make sure your card is configured
> > correctly.. (see my previous post) Channel scanning should work just
> > fine, and put all of the appropriate entries in your channels lineup. If
> > it doesn't, something else is probably wrong.
> >
> > --
> > John Sturgeon <><
> > http://www.sturgeonfamily.com/mythtv.php
> >
> >
> > _______________________________________________
> > mythtv-users mailing list
> > mythtv-users at mythtv.org
> > http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> >
> >
> >
>


More information about the mythtv-users mailing list