[mythtv-users] MythPlugins on SUSE AMD64

Nathan Allen Stratton nathan at robotics.net
Sun Dec 11 18:29:35 EST 2005


On Sat, 10 Dec 2005, Nathan Allen Stratton wrote:

> I am having some big issues compiling all of the mythplugins on SUSE 10
> AMD64. I get -lXmu errors with music and gallery and -lkhtml for browser.
>
> They both are on my box:
>
> opie:/usr/local/src/mythplugins # find / -name libkhtml.so -print
> /opt/kde3/lib64/libkhtml.so
>
> opie:/usr/local/src/mythplugins # find / -name libXmu.so -print
> /usr/X11R6/lib64/libXmu.so
>
> I tried to edit the configure scrip and add them at LIBPATHS="`echo
> $LIBPATHS $prefix/lib /lib /usr/lib /usr/local/lib /usr/X11R6/lib | sed
> s/'\/ '/' '/g` " (line 265), but that did not help.
>
> Errors:
>
> ccache g++ -shared -o libmythgallery.so glsingleview.o iconview.o main.o
> singleview.o gallerysettings.o dbcheck.o thumbgenerator.o qtiffio.o
> galleryutil.o moc_glsingleview.o moc_iconview.o moc_singleview.o
> -L/usr/lib64/ -L/usr/kde/3.3/lib -L/usr/lib/qt3/lib64/ -L/usr/lib64/
> -L/usr/local/lib -lexif -ltiff -lqt-mt -lGLU -lGL -lXmu -lpthread
> /usr/lib64/gcc/x86_64-suse-linux/4.0.2/../../../../x86_64-suse-linux/bin/ld:
> cannot find -lXmu
>
> ccache g++  -o mythbrowser main.o webpage.o tabview.o moc_webpage.o
> moc_tabview.o   -L/usr/lib64/ -L/usr/kde/3.3/lib -L/usr/lib/qt3/lib64/
> -L/usr/local/lib -lmyth-0.19 -lfreetype -lmp3lame -lasound -ljack
> -L/usr/X11R6/lib64/ -lXinerama -lXv -lXxf86vm -L/opt/kde3/lib -lkhtml
> -lqt-mt -lXext -lX11 -lm -lpthread
> /usr/lib64/gcc/x86_64-suse-linux/4.0.2/../../../../x86_64-suse-linux/bin/ld:
> cannot find -lkhtml

Well, I found a solution, it is sorta grose, but it works.

opie:/usr/lib64 # ln -s /usr/X11R6/lib64/libXmu.so libXmu.so
opie:/usr/lib64 # ln -s /opt/kde3/lib64/libkhtml.so libkhtml.so


><>
Nathan Stratton
nathan at robotics.net
http://www.robotics.net


More information about the mythtv-users mailing list