[mythtv-users] Re: Please help me get sorting working properly in Mythweb

Chris Petersen lists at forevermore.net
Fri Dec 16 11:44:54 EST 2005


> The mythweb config.php comments states "set this to the name or IP you
> use to access this server" when defining server_domain, but I imagine
> this should explicitly state DNS name, as using my hosts name still
> failed, even though I use this to access the server without issue.
> 
> If anyone out there reads this - why does mythweb have an issue whilst
> phpMyAdmin didn't? In my limited understanding of the server setup,
> both are using Apache and PHP to operate - I'd have thought either
> both would work, or both would fail.

This is really strange.  Cookies are controlled *entirely* by the 
browser.  When MythWeb sets a cookie, it sets the cookie domain owner to 
server_domain -- nothing more, nothing less (as opposed to a wildcard 
domain cookie like .forevermore.net which would match ANY host in the 
forevermore.net domain).

It's entirely up to the browser to store cookies, and send them back to 
the appropriate host.  If you want to track down cookie problems, first 
visit MythWeb, then look in your browser's cookie list to see what 
cookie is created.  Make sure that the domain listed for the cookie 
matches the name you use to access the server.  There's no difference 
between a hosts entry and "real" DNS entry to the client machine (that's 
sort of the whole point of the hosts file).

However, I'm happy to fix things if someone can find a bug in the cookie 
portion of MythWeb.  I've never had any issues with it, but I do run 
"real" DNS and name-based virtual hosts (which also work fine with hosts 
entries since the server only cares what hostname the browser says it's 
looking for -- server doesn't care how the browser determined its IP).

-Chris


More information about the mythtv-users mailing list