[mythtv-users] pvr-350 Live Tv Audio to remote frontend Question

David Ellis david at ellisonline.ca
Thu Dec 29 18:34:10 EST 2005


"alsa:default" will work if you type it into the output device field.

It is not available in the drop down.

David

-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Jim Duda
Sent: Thursday, December 29, 2005 6:17 PM
To: Jeff Simpson
Cc: Discussion about mythtv
Subject: Re: [mythtv-users] pvr-350 Live Tv Audio to remote frontend
Question

Jeff,

One  more note, I just realized that MythMusic has muted audio as well. 

When I do fuser -v /dev/dsp, I see that mythfrontend owns /dev/dsp.

My .asoundrc contains the following:  Note: my setup is a tad odd, I 
need to put my main audio output on /dev/dsp1, which I reroute using the 
alsa "default" using my .asoundrc.

I found that if I changed the MythMusic settting to use /dev/dsp1, 
instead of /dev/dsp, I get music audio.
However, changing the Video settings to use /dev/dsp1, still results in 
no audio for MythTV recordings, but audio for Freevo recordings.
This is a very strange issue.

Is there any way to define the audio to use "alsa:default" instead of 
/dev/dsp ?

pcm.!default {
  type plug
  slave.pcm "dmixer1"
}
pcm.dsp1 {
  type plug
  slave.pcm "dmixer1"
}
pcm.dmixer1 {
  type dmix
  ipc_key 1026
  slave {
    pcm "hw:1,0"
    period_time 0
    period_size 2048
    buffer_size 32768
    rate 48000
  }
  bindings {
    0 0
    1 1
  }
}

pcm.jackplug {
  type plug
  slave { pcm "jack" }
}

pcm.jack {
  type jack
  playback_ports {
    0 alsa_pcm:playback_1
    1 alsa_pcm:playback_2
  }
  capture_ports {
    0 alsa_pcm:capture_1
    1 alsa_pcm:capture_2
  }
}

Jim

Jeff Simpson wrote:

> On 12/29/05, *Jim Duda* <jim at duda.tzo.com <mailto:jim at duda.tzo.com>> 
> wrote:
>
>     I'm currently an avid Freevo user.  I just installed MythTV
>     yesterday and
>     started playing with it.  Mythtv is very impressive.
>
>     I have mythbackend running on one linux box, with a PVR-350 tuner
>     card.  I
>     have mythfrontend installed and running on multiple linux
>     boxes.  I can
>     view and hear mpeg videos on all the frontend boxes.  For live TV,
>     I can
>     see the video, but I cannot hear the audio.
>
>     I've read the mailing list and found a couple of postings on this
>     topic.
>     It's my understanding that the livetv audio from a Pvr-350 is
>     exported out
>     of the rear audio jack and not through the PCI bus like it would
>     with the
>     mpeg stream.  Connecting the PVR-350 audio output back into a
>     sound card
>     input would allow a mythfrontend to hear audio, however, only on
>     the box
>     which contains the pvr-350 tuner.  This doesn't help any remote
>     frontend
>     boxes.
>
>
> Not entirely correct. The PVR-350 takes audio in and saves it with the 
> MPEG automatically. If you want to output to TV, you can use the audio 
> out of the PVR as well. The loopback audio cable is just to allow that 
> machine to play other audio sources to the TV (mythmusic, mythgame, 
> etc, things that require /dev/dsp). So in the case of remotely playing 
> liveTV, you should not need to use that loopback.
>
>     Is there any means to get the audio from a pvr-350 in a
>     mythbackend to the
>     mythfrontend on another machine?  Are there any plans to address
>     this in
>     future releases?
>
>
> I have 0.18.1 running on my backend/frontend machine with a 350 as 
> well as a frontend only on my laptop, and audio works in all cases, 
> live and recorded. You say that it can play mpeg videos on the 
> back/frontends - do you mean other mpeg videos, or the ones that are 
> recorded by myth?
>
> I'd also take a look at the frontend logs and setup to make sure the 
> audio is set up properly. Additionally, check to see that the mpegs do 
> contain the audio - you should be able to just play the .nuv files 
> with a fairly recent version of mplayer on any linux machine.
>  
>
>     In my freevo environment, I handle the remote livetv issue using mpeg
>     streaming from videolan ( www.videolan.org
>     <http://www.videolan.org>).  It works okay, however,
>     mythtv appears much nicer and more integrated, albiet, no audio from a
>     pvr-350.  I'd really like to get this working an give mythtv a
>     shot at
>     replacing freevo.
>
>  
> That's the same way myth handles remote frontends, by streaming the 
> mpeg. Alternatively, you can also remote-mount the fs and play them 
> that way, but streaming is easy enough and works.
>
> A likely thing to try is in the remote frontend setup, where it says 
> "Use PVR-350 Output" you want to say NO. That option is only for the 
> machine with the PVR in it - using that option on another machine will 
> make the video and audio try to play through the 350, which won't be 
> there, and won't work. You should set it up to use /dev/dsp or 
> whatever the equivalent device is for your system.

_______________________________________________
mythtv-users mailing list
mythtv-users at mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users



More information about the mythtv-users mailing list