[mythtv-users] Freqid and Sky Digital

Darren Coleman daz at superficial.net
Fri Jul 8 05:50:44 EDT 2005


Hi,

Hoping someone out there can help me.

I've got MythTV receiving input from a Sky Digital STB, via a Hauppauge
PVR-350.  The signal is coming via S-video into the S-video IN on my PVR350.
Everything appears to be working correctly except for one small problem -
changing channels.

Running tv_grab_uk_rt does not populate any freqids in the database (wait, I
know you're going to say mythfilldatabase --manual) but in actuality I don't
need Myth/ivtv or whatever to "tune" to the selected station, it simply
needs to send 3 numbers to the box and the box changes it.

Right now when I press the arrow keys to go up or down a channel it just
pauses for a while and then comes back with the same channel information.  I
understand from the debugging output that this is because there are missing
freqids from the "europe-west" freqtable I am using (e.g. SE11, E8, etc).

If I run "ptune.pl -f pal-europe-west --list-channels" I get a list of known
frequency IDs.  I *could* use these freqids to populate the database
manually, but the problem there then is that there are only 109 known
freqids, and I have - from memory - at least 160 channels in the database.

All I basically want Myth to do when I type in a channel number, or press
up/down on the cursor keys is to adjust the program guide and OSD
accordingly.  I don't need it to try and *tune* anything, since ultimately I
will have to get it set up so it sends the necessary numbers down an IR
"Redeye" or similar bit of kit to change it.

Any ideas?  I can't believe I'm the first person to hit this problem, and
yet I couldn't find any specific info anywhere in the archives.

Regards,

Darren



More information about the mythtv-users mailing list