[mythtv-users] OT: kernel disabling IRQ#7 (Sound Stops working)

Mark Knecht markknecht at gmail.com
Mon Jul 11 11:35:17 EDT 2005


Hi,
First, let's be sure that the sound card is on IRQ7

cat /proc/interrupts

If IRQ7 is the correct interrupt then typical reason that interrupts
will get disabled is that the interrupt controller is receiving
spurious interrupts on that channel. The interrupt happens, the
interrupt service routine goes to read all the chips on that IRQ and
finds that no chip says it generated the interrupt. Normally after a
few of these the system will shut down the channel and interrupts for
all devices on that channel are hosed.

There are typically a few normal reasons for this stuff:

1) The system has some design problem. Internal noise messes with IRQ
line on the motherboard.

2) A chip is bad or going bad. This could be the chipset of the sound card.

Possible solutions:

a) If the sound card is sharing and interrupt with other cards or
devices then try to isolate the sound card on it's own interrupt. Try
placing it in a different PCI slot.

b) If this is an onboard sound ship then ensure that no other decide
you have control over shares the interrupt. I.e. - if the sound card
is sharing an interrupt with a PCI Ethernet adapter then try moving
the NIC to another slot.

c) If the above ideas don't work and this is a PCI device then try
another sound card

d) It is possible hat the problem is on the motherboard itself. The
solution for that is not pretty.

e) All of this can be caused by bad programming of the chipset.
Investigate other kernels or distros for this sort of problem &
potential solutions. Some distros add patches, some don't. Try a
kernel.org kernel instead of a prepackaged kernel.

   Good luck. I've struggled through this a couple of times over the
years. There are usually solutions but they are not (in my experience)
always easy to find.

Cheers,
Mark

On 7/11/05, Noel Murphy <bnmurphy at rogers.com> wrote:
> Hello,
> 
> I realize this isn't mythtv specific, however it is happening on my
> box which is used specifically for mythtv.
> 
> I have a weird issue where when I don't use the machine for awhile
> (say the whole weekend because I'm gone to the cottage) when I
> return, I have a Knotify message up on the screen telling me that the
> kernel has disabled IRQ #7 (Which I believe is the interrupt for the
> sound card). Then, when I try to watch any recordings or live tv, I
> get no sound.
> 
> A reboot always fixes the problem (until the following weekend when I
> go away again).
> 
> Anyone know why this is happening????
> 
> Noel
> 
> 
> 
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> 
> 
>


More information about the mythtv-users mailing list