[mythtv-users] DVD stuttering only in MythTV

Scott catfather at donpoo.net
Tue Jul 12 11:20:48 EDT 2005


On Jul 12, 2005, at 8:00 AM, Scott wrote:
>
> The problem is when subtitles or Closed Captions are enabled that  
> xine playback of the DVD seems to stutter just at the moment when  
> the text appears on the screen. This happens every time new text  
> appears on the screen and is most noticeable when the camera is  
> panning across backgrounds or as the camera follows a group of  
> people walking down a hall way. I've run xine with the bug-report  
> option and don't see any error output when the problem shows up.
>
> If I exit from MythTV and use xine from a xterm to play back the  
> same DVD with subtitles or Closed Captions I don't see the problem.  
> In other words, xine launched from outside of MythTV shows no  
> stutter problems with the DVD playback where xine launched from  
> within MythTV shows a problem with stuttering on DVDs when  
> subtitles or Closed Captions are enabled. In both cases the command  
> line for xine is "xine -pf --no-splash dvd://" and the xine config  
> file is set to use XV for video and ASLA passthrough the SPDIF for  
> audio.

Some nice folks on the xine-user list pointed me in the direction of  
Xv color key issues. While I'm still doing tests it seems that  
enabling the following in my .xine/config solved the stutter with  
subtitles/cc problem:

# autopaint colour key
# bool, default: 0
video.device.xv_autopaint_colorkey:1

--
Scott <catfather at donpoo.net>
AIM: BlueCame1



More information about the mythtv-users mailing list