[mythtv-users] OT: Hooking up to my HDTV using DVI

Mark Frey markfrey at fastmail.fm
Sat Jul 16 16:21:03 EDT 2005


I'm having no luck at all getting my Myth to display on my HDTV. I'm using
the DVI out on my FX5200 to connect to the HDMI on my TV using a DVI-HDMI
cable. I've tried all the modelines listed by Jarrod, and many other
modelines I've found searching around the web (see xorg.conf stuff below).
I've tried several different versions of the Nvidia drivers, all to no
avail. The X logs show X switching to the appropriate modes, but I never get
a picture. The TV acts as if there is no signal at all. I've tried
1920x1080i, 1920x540p, 960x540p, all with several different timings.
Nothing. No rolling picture, no offset picture, no picture period.

Is this normal? I know that few if any have gotten 1080i to work with the
Nvidia drivers, but from reading around it seems like people have usually
gotten 540p to work.

What I'm wondering is if I'm missing something really obvious. I could get
one of the AudioAuthority 9a60 converter, but before I spend $130 I want to
make sure I'm not doing something stupid.

My TV is a Sony KP-46WT520, it's EDID reports 540p as the resolution. I've
tried with "IgnoreEDID" both on and off, etc.

Does anyone have any hints for me?

Has anyone similarly had no luck at all using DVI and gotten the
AudioAuthority or some other converter to work?


Here are the relavent portions of my xorg.conf and Xorg.0.log:

--------------------------------xorg.conf (note that this is not the whole
file)----------------------------------
Section "ServerLayout"
 Identifier     "X.org Configured"
 Screen      0  "ScreenHDTV" 0 0
 InputDevice    "Mouse0" "CorePointer"
 InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Module"
 Load  "extmod"
 #Load  "dri"
 Load  "dbe"
 Load  "record"
 Load  "xtrap"
 Load  "glx"
 Load  "type1"
 Load  "freetype"
EndSection


Section "Monitor"
    Identifier  "HDTV Out"
    VendorName  "Sony"
    ModelName   "46 inch"
    Option      "ConnectedMonitor" "DFP"
    Option      "IgnoreDisplayDevices" "CRT,TV"
    #Option     "dpms"
    HorizSync    15-46
    VertRefresh  59-61
    #Modeline "540pw" 79.912 1920 2040 2200 2368 540 550 551 563 +hsync
+vsync
#    Modeline "540p" 39.956 960 1020 1100 1184 540 550 551 563 +hsync +vsync
    #Modeline "540p" 39.956 960 1020 1100 1184 540 550 551 563

    Modeline "A540" 37.26 960 976 1008 1104 540 542 548 563 +hsync +vsync

    ModeLine "1080i"     73.943 1776 1920 1976 2208 1000 1038 1043 1125
interlace +hsync +vsync
    Modeline "1920x1080" 74.250 1920 2008 2052 2200 1080 1084 1094 1124
interlace +hsync +vsync
    Modeline "540p" 39.0 960 984 1016 1136 540 550 556 580 +hsync +vsync
    ModeLine "ATSC-480-59.94i" 11.958 640 664 736 760 480 484 492 525
Interlace
    ModeLine "ATSC-480-60i" 11.97 640 664 736 760 480 484 492 525 Interlace
    ModeLine "ATSC-480-59.94p" 23.916 640 664 736 760 480 484 492 525
    ModeLine "ATSC-480-60p" 23.94 640 664 736 760 480 484 492 525
    ModeLine "ATSC-480a-59.94i" 11.958 640 664 736 760 480 484 492 525
Interlace
    ModeLine "ATSC-480a-60i" 11.97 640 664 736 760 480 484 492 525 Interlace
    ModeLine "ATSC-480a-59.94p" 23.916 640 664 736 760 480 484 492 525
    ModeLine "ATSC-480a-60p" 23.94 640 664 736 760 480 484 492 525
    ModeLine "ATSC-1080-59.94i" 74.176 1920 1960 2016 2200 1080 1082 1088
1125 Interlace
    ModeLine "my540" 74.176 1920 1960 2016 2200 540 541 544 563 +hsync
+vsync
    ModeLine "ATSC-1080-60i" 74.25 1920 1960 2016 2200 1080 1082 1088 1125
Interlace
    ModeLine "my540b" 74.25 1920 1960 2016 2200 540 541 544 563 +hsync
+vsync
    ModeLine "ATSC-1080-59.94p" 148.352 1920 1960 2016 2200 1080 1082 1088
1125
    ModeLine "ATSC-1080-60p" 148.5 1920 1960 2016 2200 1080 1082 1088 1125
    ModeLine "ATSC-720-59.94p" 74.086 1280 1320 1376 1648 720 722 728 750
    ModeLine "ATSC-720-60p" 74.16 1280 1320 1376 1648 720 722 728 750

EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "DigitalVibrance"     # <i>
        #Option     "NoFlip"              # [<bool>]
        #Option     "Dac8Bit"             # [<bool>]
        #Option     "NoLogo"              # [<bool>]
        #Option     "UBB"                 # [<bool>]
        #Option     "Stereo"              # <i>
        #Option     "SWcursor"            # [<bool>]
        #Option     "HWcursor"            # [<bool>]
        #Option     "VideoKey"            # <i>
        Option     "NvAGP" "1"              # <i>
        Option     "IgnoreEDID" "1"         # [<bool>]
        Option     "NoDDC" "1"               # [<bool>]
        #Option     "ConnectedMonitor"    # <str>
        #Option     "ConnectedMonitors"   # <str>
        #Option     "TVStandard"          # <str>
        #Option     "TVOutFormat"         # <str>
       #Option     "RenderAccel" "1"         # [<bool>]
        #Option     "CursorShadow"        # [<bool>]
        #Option     "CursorShadowAlpha"   # <i>
        #Option     "CursorShadowXOffset"  # <i>
        #Option     "CursorShadowYOffset"  # <i>
       #Option     "UseEdidFreqs" "1"       # [<bool>]
        #Option     "FlatPanelProperties"  # <str>
        #Option     "TwinView"            # [<bool>]
        #Option     "TwinViewOrientation"  # <str>
        #Option     "SecondMonitorHorizSync"  # <str>
        #Option     "SecondMonitorVertRefresh"  # <str>
        #Option     "MetaModes"           # <str>
        #Option     "UseInt10Module"      # [<bool>]
        #Option     "NoTwinViewXineramaInfo"  # [<bool>]
        #Option     "NoRenderExtension"   # [<bool>]
        #Option     "Overlay"             # [<bool>]
        #Option     "CIOverlay"           # [<bool>]
        #Option     "ForceEmulatedOverlay"  # [<bool>]
        #Option     "TransparentIndex"    # <i>
        #Option     "OverlayDefaultVisual"  # [<bool>]
        #Option     "NvEmulate"           # <i>
        #Option     "NoBandWidthTest"     # [<bool>]
        #Option     "CustomEDID-CRT-0"    # <str>
        #Option     "CustomEDID-CRT-1"    # <str>
        #Option     "CustomEDID-DFP-0"    # <str>
        #Option     "CustomEDID-DFP-1"    # <str>
        #Option     "CustomEDID-TV-0"     # <str>
        #Option     "CustomEDID-TV-1"     # <str>
       #Option     "TVOverScan" "0.979"          # <f>
        #Option     "IgnoreDisplayDevices"  # <str>
        #Option     "MultisampleCompatibility"  # [<bool>]
        #Option     "RegistryDwords"      # <str>
        #Option     "RegistryBinary"      # <str>
        #Option     "NoPowerConnectorCheck"  # [<bool>]
        #Option     "AllowDFPStereo"      # [<bool>]
        Option     "XvMCUsesTextures" "1"   # [<bool>]
        #Option     "HorizSync"           # <str>
        #Option     "VertRefresh"         # <str>
        #Option     "AllowGLXWithComposite"  # [<bool>]
        #Option     "RandRRotation"       # [<bool>]
        Option     "ExactModeTimingsDVI" "1" # [<bool>]
 Identifier  "Card0"
 Driver      "nvidia"
 VendorName  "nVidia Corporation"
 BoardName   "NV34 [GeForce FX 5200]"
 BusID       "PCI:1:0:0"

EndSection

Section "Screen"
    Identifier "ScreenHDTV"
    Device "Card0"
    Monitor "HDTV Out"
    DefaultDepth 24
    Subsection "Display"
        Depth 24
        #Modes "ATSC-720-59.94p"
        Modes "my540b"
        #Modes "ATSC-480-59.94p"
        #Modes "540p"
        #Modes "540pw"
        #Modes "ATSC-1080-59.94i"
        #Modes "1920x1080"
        #Modes "1080i"
        #Modes "A540"
    EndSubSection
EndSection

-------------------------Xorg.0.log------------------------------------

X Window System Version 6.8.2
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.12-rc1 i686 [ELF]
Current Operating System: Linux mgm 2.6.11.4 #3 Mon Mar 28 19:58:48 PST 2005
i686
Build Date: 19 March 2005
 Before reporting problems, check http://wiki.X.Org
 to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
 (++) from command line, (!!) notice, (II) informational,
 (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul  9 13:02:53 2005
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "ScreenHDTV" (0)
(**) |   |-->Monitor "HDTV Out"
(**) |   |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(WW) The directory "/usr/share/fonts/CID/" does not exist.
 Entry deleted from font path.
(**) FontPath set to
"/usr/share/fonts/misc/,/usr/share/fonts/TTF/,/usr/share/fonts/Type1/,/usr/s
hare/fonts/75dpi/,/usr/share/fonts/100dpi/"
(**) RgbPath set to "/usr/lib/X11/rgb"
(**) ModulePath set to "/usr/lib/modules"
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) Module ABI versions:
 X.Org ANSI C Emulation: 0.2
 X.Org Video Driver: 0.7
 X.Org XInput driver : 0.4
 X.Org Server Extension : 0.2
 X.Org Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="X.Org Foundation"
 compiled for 6.8.2, module version = 1.0.0
 Module class: X.Org Font Renderer
 ABI class: X.Org Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/modules/libpcidata.a
(II) Module pcidata: vendor="X.Org Foundation"
 compiled for 6.8.2, module version = 1.0.0
 ABI class: X.Org Video Driver, version 0.7
Using vt 7
(--) using VT number 7

---snip---

(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:31:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) nVidia Corporation NV34 [GeForce FX 5200] rev 161, Mem @
0xeb000000/24, 0xd8000000/27
(--) PCI: (2:1:0) unknown vendor (0x4444) unknown chipset (0x0016) rev 1,
Mem @ 0xe0000000/26
(--) PCI: (2:3:0) unknown vendor (0x14f1) unknown chipset (0x8800) rev 5,
Mem @ 0xe8000000/24

---snip---

(II) LoadModule: "glx"
(II) Loading /usr/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
 compiled for 4.0.2, module version = 1.0.7667
 Module class: XFree86 Server Extension
 ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX

---snip---

(II) LoadModule: "nvidia"
(II) Loading /usr/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
 compiled for 4.0.2, module version = 1.0.7667
 Module class: XFree86 Video Driver

---snip---

(II) NVIDIA X Driver  1.0-7667  Fri Jun 17 07:03:12 PDT 2005
(II) NVIDIA Unified Driver for all NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(--) Chipset NVIDIA GPU found

---snip---

(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NvAGP" "1"
(**) NVIDIA(0): Option "IgnoreEDID" "1"
(**) NVIDIA(0): Option "NoDDC" "1"
(**) NVIDIA(0): Option "ConnectedMonitor" "DFP"
(**) NVIDIA(0): Option "IgnoreDisplayDevices" "CRT,TV"
(**) NVIDIA(0): Option "XvMCUsesTextures" "1"
(**) NVIDIA(0): Option "ExactModeTimingsDVI" "1"
(**) NVIDIA(0): Use of NVIDIA internal AGP requested
(**) NVIDIA(0): Ignoring EDIDs
(**) NVIDIA(0): ConnectedMonitor string: "DFP"
(--) NVIDIA(0): Linear framebuffer at 0xD8000000
(--) NVIDIA(0): MMIO registers at 0xEB000000
(II) NVIDIA(0): NVIDIA GPU detected as: GeForce FX 5200
(--) NVIDIA(0): VideoBIOS: 04.34.20.18.00
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(II) NVIDIA(0): Detected AGP rate: 4X
(--) NVIDIA(0): VideoRAM: 131072 kBytes
(II) NVIDIA(0): Using ConnectedMonitor string "DFP-0"
(--) NVIDIA(0): DFP-0: maximum pixel clock: 135 MHz
(--) NVIDIA(0): DFP-0: Internal Single Link TMDS
(II) NVIDIA(0): Not probing EDIDs.
(II) NVIDIA(0): HDTV Out: Using hsync range of 15.00-46.00 kHz
(II) NVIDIA(0): HDTV Out: Using vrefresh range of 59.00-61.00 Hz
(II) NVIDIA(0): Clock range:  12.00 to 135.00 MHz
(II) NVIDIA(0): Not using mode "ATSC-480-59.94i" (bad mode
clock/interlace/doublescan)
(II) NVIDIA(0): Not using mode "ATSC-480-60i" (bad mode
clock/interlace/doublescan)
(II) NVIDIA(0): Not using mode "ATSC-480a-59.94i" (bad mode
clock/interlace/doublescan)
(II) NVIDIA(0): Not using mode "ATSC-480a-60i" (bad mode
clock/interlace/doublescan)
(II) NVIDIA(0): Not using mode "ATSC-1080-59.94p" (bad mode
clock/interlace/doublescan)
(II) NVIDIA(0): Not using mode "ATSC-1080-60p" (bad mode
clock/interlace/doublescan)

---snip---

(II) NVIDIA(0): Not using mode "1920x1080" (height too large for virtual
size)
(II) NVIDIA(0): Not using mode "ATSC-1080-59.94i" (height too large for
virtual size)
(II) NVIDIA(0): Not using mode "ATSC-1080-60i" (height too large for virtual
size)
(II) NVIDIA(0): Not using mode "1080i" (height too large for virtual size)
(II) NVIDIA(0): Not using mode "ATSC-720-59.94p" (height too large for
virtual size)
(II) NVIDIA(0): Not using mode "ATSC-720-60p" (height too large for virtual
size)
(II) NVIDIA(0): Not using default mode "800x600" (height too large for
virtual size)
(**) NVIDIA(0): Validated modes for display device DFP-0:
(**) NVIDIA(0):      Mode "my540b": 74.2 MHz, 33.8 kHz, 59.9 Hz
(**) NVIDIA(0):      Mode "my540": 74.2 MHz, 33.7 kHz, 59.9 Hz
(**) NVIDIA(0):      Mode "A540": 37.3 MHz, 33.8 kHz, 59.9 Hz
(**) NVIDIA(0):      Mode "540p": 39.0 MHz, 34.3 kHz, 59.2 Hz
(**) NVIDIA(0):      Mode "ATSC-480-59.94p": 23.9 MHz, 31.5 kHz, 59.9 Hz
(**) NVIDIA(0):      Mode "ATSC-480-60p": 23.9 MHz, 31.5 kHz, 60.0 Hz
(**) NVIDIA(0):      Mode "ATSC-480a-59.94p": 23.9 MHz, 31.5 kHz, 59.9 Hz
(**) NVIDIA(0):      Mode "ATSC-480a-60p": 23.9 MHz, 31.5 kHz, 60.0 Hz
(**) NVIDIA(0):      Default mode "640x480": 25.2 MHz, 31.5 kHz, 60.0 Hz
(**) NVIDIA(0):      Default mode "400x300": 20.0 MHz, 37.9 kHz, 60.3 Hz (D)
(**) NVIDIA(0):      Default mode "320x240": 12.6 MHz, 31.5 kHz, 60.1 Hz (D)
(II) NVIDIA(0): Virtual screen size determined to be 1920 x 540
(==) NVIDIA(0): DPI set to (75, 75)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/modules/libfb.a
(II) Module fb: vendor="X.Org Foundation"
 compiled for 6.8.2, module version = 1.0.0
 ABI class: X.Org ANSI C Emulation, version 0.2
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/lib/modules/libramdac.a
(II) Module ramdac: vendor="X.Org Foundation"
 compiled for 6.8.2, module version = 0.1.0
 ABI class: X.Org Video Driver, version 0.7
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.

---snip---

(II) NVIDIA(0): Setting mode "my540b"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) Loading extension NV-CONTROL
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX

---snip---




More information about the mythtv-users mailing list