[mythtv-users] Re: apt-get on FC3 still broken?

Jerry Rubinow jerrymr at gmail.com
Thu Jul 28 10:48:05 EDT 2005


On 26/07/05, Jerry Rubinow <jerrymr at gmail.com> wrote:
> I'm at the point where I've done an apt-get update, but before the apt
> and rpm-destroying apt-get dist-upgrade.  If I do this:
> 
> apt-get install rpm librpm4.4 apt atrpms-package-config fedora-release beecrypt
> 
> I get the error that, er, Evil Barney mentioned:
> 
> > The following packages have unmet dependencies:
> >   rpm: Depends: libselinux (>= 1.23.2) but 1.19.1-8 is to be installed
> > E: Broken packages

After trying a bunch of suggestions from Axel, we found that the
following works:

Before the apt-get dist-upgrade, try emptying /etc/apt/preferences, then doing:

apt-get update
apt-get install rpm librpm4.4 apt atrpms-package-config fedora-release beecrypt
apt-get dist-upgrade

The second line is probably not necessary once the preferences file is
cleared, but I didn't explicitly try omitting it.  See

http://bugzilla.atrpms.net/show_bug.cgi?id=587

for more details.

-Jerry


More information about the mythtv-users mailing list