[mythtv-users] mythtv debian/sarge

George Nassas gnassas at mac.com
Sat Jul 30 12:24:17 EDT 2005


On 30-Jul-05, at 4:23 AM, Brian May wrote:

> Is there anywhere I can get precompiled versions of Mythtv for
> Debian/sarge, now Debian/stable?
>
> I use to use http://dijkstra.csh.rit.edu/~mdz/debian/ unstable, but
> unfortunately some of the files (in particular DVD support) appear to
> have been compiled with gcc-4.0, and as such require Debian unstable.

Those are the best debian packages around so I would try to adapt them 
to your setup. It's easy enough to build the source packages if you 
need them tailored to your machine and if you're handy you can even get 
the source packages to build current svn. My build logs show 
debian/rules running configure with CC=gcc-3.4 CXX=g++-3.4 LINK=g++-3.4 
so it doesn't look like gcc-4.0 is in the picture.

I'm not sure if you can install myth on a purely stable system. I run a 
mixed setup where the apt priorities favour stable then testing then 
unstable and things work pretty well but I'm not sure how many 
dependancy packages I'm picking up from each area.

- George



More information about the mythtv-users mailing list