[mythtv-users] ALSA Sound and Video Modes

Brandon Rogers blrogers at ieee.org
Sun Jul 31 20:21:01 EDT 2005


If this helps on the sound question, if I switch over to the standard audio
out jack, then I get sound as well.  Seems like the sound is being routed
correctly over the SPDIF

Thanks,
Brandon

-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Brandon Rogers
Sent: Sunday, July 31, 2005 7:16 PM
To: 'Discussion about mythtv'
Subject: RE: [mythtv-users] ALSA Sound and Video Modes

Thanks everyone who replied on this and helped out.  The sound is still not
working, but holding my finger next to the optical out on the back of the
card shows light, so I suppose that it is working from the point of view of
my computer, anyway.  My surround sound receiver isn't recognizing the
signal unfortunately.  I guess the only three possible problems is that the
sound is being encoded in a way that the receiver doesn't understand, the
light isn't actually carrying any sound and I still have a configuration
problem, or the receiver has a broken optical in (which has never been used
before, so who knows...).  I think (hope) it is probably the second or first
one, but I'll keep playing with it.  If you have ANY suggestions, I'm
pleased to receive them.

Also, at first, I thought the clarity of the 1080i (540p in some cases) is
actually better than the NTSC output.  However, after playing with things,
I'm not sure this is the case.  Most of the clarity seems to come from
simply having such a low resolution (the text is huge).  Sure, there is
*some* clarity enhancements, but seeing as the resolution is so low, I
wonder if it is really worth it.  I can crank my resolution up, modulate it
to NTSC, and I get more screen real estate, the picture quality (for an
average video user) are very close (admittedly, the 1080i/540p is better),
but by how much and is it really worth it?  What does everyone think?

Thanks,
Brandon

PS. I am piping the video to an HDTV over DVI->HDMI.  

-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Michael Ford
Sent: Sunday, July 31, 2005 5:57 PM
To: Discussion about mythtv
Subject: Re: [mythtv-users] ALSA Sound

Create a .asoundrc file with the following and place it into the home 
directory of the myth user.   Then use ALSA:default or ALSA:spdif in Mythtv 
and Mythmusic.  Also, make sure you turn off "Multi Track Rate Locking" if 
enabled or you will get sound output at the wrong speed.  This will 
effectively output all sound through your optical out so your 
receiver/processor can do all the work.

pcm.!default {
    type plug
    slave.pcm "cards.pcm.iec958"
}

pcm.!spdif {
    type plug
    slave.pcm "cards.pcm.iec958"
}

pcm.!iec958 {
    type plug
    slave {
    pcm "hw:0,1"
    format S32_LE
    }
}

Mike Ford


On Sunday 31 July 2005 1:41 pm, Brandon Rogers wrote:
> All,
>
>             I know this has probably been talked about before, but since
> after 2 days of searching Google and trying "solutions" others have
posted,
> I will come back and ask a question (which has probably already been asked
> 1000 times).  I have the Chaintech AV710 soundcard which seems like a
> popular card due to its price/performance.  How do I get this card's
> optical out to work with my Surround Sound Amplifier?  Does it output 5.1
> Surround? If so, what do I need to do to get it to work?  I've read the
> MythTV Fedora HowTO and the links off that page in attempt to get the
sound
> to work.  I've replaced a zillion alsa sound files, but still doesn't
work.
>  If I route the sound to PCM out, I can hear it off the Line Out port.
>
>
>
> Thanks for your help!
>
> Brandon
_______________________________________________
mythtv-users mailing list
mythtv-users at mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users






More information about the mythtv-users mailing list