[mythtv-users] Re: How I solved my PVR-350 hard lockup problem

John Kuhn kuhn at razorsys.com
Fri Mar 11 00:33:07 UTC 2005


jerome lacoste wrote:

>On Thu, 10 Mar 2005 22:17:22 +0000, Ryan Dalzell <ryan at tullyroan.com> wrote:
>  
>
>>Hi Guys,
>>
>>I just recently did some fiddling with my machine and - of course - created
>>severe havoc and much domestic turmoil for days afterwards. The box would
>>hard lock (hang) and have to be power cycled. Then it would hang again.
>>There is seemingly no pattern to when these would happen. I could watch
>>LiveTV for hours and then change channel and it would hang.
>>
>>I've fixed it now but I noticed plenty of other people having the same very
>>frustrating problem. 
>>    
>>
>
>
>I am part of those. I thought about the power supply. 
>
>Just a question: your machine seems to be a simple front end, no
>tuner/DVB card, correct?
>
>My board has *only*  the PVR350, a 160G hard disk, a USB wireless key
>and a slim CDROM which I almost never use. This should fit with the
>small power supply I am using.
>
>It still crashed when I only had the disk and the tuner, no USB and no CDROM.
>
>On the other side, many people believe the problem could be related to DMA. 
>
>There's a thread about that here:
>
>http://forums.viaarena.com/messageview.aspx?catid=28&threadid=60131&STARTPAGE=1#391672
>
>I am also seeing a lot of DMA errors in the logs. You can check the
>ivtv-dev list for a post from me and other people with simlar issue.
>
>So if the problem is DMA related, removing the disk would also solve
>it. If I understand, your disk is only used as a storage element.
>
>If you have time, could you try to put the disk back, but disable DMA
>(in BIOS and in OS)?
>
>That way we will perhaps see if the problem was the power supply or the DMA...
>
>Cheers,
>
>Jerome
>  
>
i came to the same conclusion with my VIA experiance with the 350.. the 
problem came down to the I/O.. and DMA issues..

--John


More information about the mythtv-users mailing list