[mythtv-users] Problems getting PVR-500 tuner working

Jim Kusznir jim at kusznir.net
Wed Mar 23 05:52:14 UTC 2005


hello all:

I recently bought a PVR-500 and installed it next to my PVR-250, and 
upgraded to ivtv-0.3.2j.  The PVR-250 is reconized and working (S-video 
in; I don't have CATV attached to it, never tested the tuning ability).  
The drivers autodetect the 500 as 2 150's (which I expected), and appear 
to identify the tuner and all.  Furthermore, if I hook up my composite 
source and select the proper input, the "first card" works fine.

However, when I hook up the RF CATV feed to the card and attempt to use 
its tuner function (either tuner; it doesn't seem to make a difference), 
I get a redish static that seems to grow in intensity until it goes to a 
completely black screen, and starts growing again.  It doesn't look like 
"snow" or other traditional mis-tuned static.  I get the same results 
reguardless of which tuner input I select.

In case it makes a difference (or explains why I have things set up the 
way I do), I subscribe to digital cable.  However, 85% of what I 
watch/record happens to be on the analog portion of the cable.  So I 
figured I'd put a PVR-500 and feed it with RF, providing 2 tuners 
capable of getting channels 2-74, and one capture card (pvr-250) capable 
of getting the whoe thing through the cable box.  All aspects of the 250 
in my situation work fine (I've never hooked up RF CATV directly to the 
250, so I don't know if the tuner does or ever has worked on it).

Any suggestions?  Oh yea, I'm in NTSC-land (US).

Here's my ivtv loading output:

Mar 22 21:19:07 mythtv ivtv: ==================== START INIT IVTV 
====================
Mar 22 21:19:07 mythtv ivtv: version 0.3.2 (j) loading
Mar 22 21:19:07 mythtv ivtv: Linux version: 2.6.9-gentoo-r9 preempt 
PENTIUM4 4KSTACKS gcc-3.3
Mar 22 21:19:07 mythtv ivtv: In case of problems please include the 
debug info
Mar 22 21:19:07 mythtv ivtv: between the START INIT IVTV and END INIT 
IVTV lines when
Mar 22 21:19:07 mythtv ivtv: mailing the ivtv-devel mailinglist.
Mar 22 21:19:07 mythtv ivtv: Autodetected WinTV PVR 250 card
Mar 22 21:19:07 mythtv ivtv: Found an iTVC16 based chip
Mar 22 21:19:07 mythtv PCI: Enabling device 0000:02:0b.0 (0014 -> 0016)
Mar 22 21:19:07 mythtv ACPI: PCI interrupt 0000:02:0b.0[A] -> GSI 9 
(level, low) -> IRQ 9
Mar 22 21:19:07 mythtv ivtv: Unreasonably low latency timer, setting to 
64 (was 32)
Mar 22 21:19:07 mythtv ivtv: XXX PCI device: 0x2530 vendor: 0x8086
Mar 22 21:19:07 mythtv tveeprom: Hauppauge: model = 32552, rev = C168, 
serial# = 7718626
Mar 22 21:19:07 mythtv tveeprom: tuner = LG TAPE H001F MK3 (idx = 68, 
type = 47)
Mar 22 21:19:07 mythtv tveeprom: tuner fmt = NTSC(M) (eeprom = 0x08, 
v4l2 = 0x00001000)
Mar 22 21:19:07 mythtv tveeprom: audio_processor = MSP3440 (type = 11)
Mar 22 21:19:07 mythtv ivtv: i2c attach [client=tveeprom[0],ok]
Mar 22 21:19:07 mythtv ivtv: Tuner Type 47, Tuner formats 0x00001000, 
Radio: yes,Model 0x008d1598, Revision 0x00000001
Mar 22 21:19:07 mythtv ivtv: NTSC tuner detected
Mar 22 21:19:07 mythtv ivtv: Radio detected
Mar 22 21:19:07 mythtv tuner: Ignoring new-style parameters in presence 
of obsolete ones
Mar 22 21:19:07 mythtv tuner: chip found at addr 0xc2 i2c-bus ivtv i2c 
driver #0
Mar 22 21:19:07 mythtv ivtv: i2c attach [client=(tuner unset),ok]
Mar 22 21:19:07 mythtv saa7115: starting probe for adapter ivtv i2c 
driver #0 (0x10005)
Mar 22 21:19:07 mythtv saa7115: detecting saa7115 client on address 0x42
Mar 22 21:19:07 mythtv saa7115: writing init values
Mar 22 21:19:07 mythtv ivtv: i2c attach [client=saa7115[0],ok]
Mar 22 21:19:07 mythtv saa7115: status: (1E) 0x48, (1F) 0xc0
Mar 22 21:19:07 mythtv msp34xx: ivtv version
Mar 22 21:19:07 mythtv msp34xx: init: chip=MSP3448W-A2, has NICAM 
support, simple(D) mode, simpler (G) no-thread mode
Mar 22 21:19:07 mythtv msp34xx: $Id$ compiled on: Mar 19 2005 23:39:57
Mar 22 21:19:07 mythtv ivtv: i2c attach [client=MSP3448W-A2,ok]
Mar 22 21:19:07 mythtv ivtv: Encoder revision: 0x02040024
Mar 22 21:19:07 mythtv ivtv: Encoder Firmware may be buggy, use version 
0x02040011
Mar 22 21:19:07 mythtv ivtv: Configuring WinTV PVR 250 card with 5 streams
Mar 22 21:19:07 mythtv ivtv: Registered v4l2 device, streamtype 0 minor 0
Mar 22 21:19:07 mythtv ivtv: Create DMA stream 0 using 1024 16384 byte 
buffers  0kbytes total
Mar 22 21:19:07 mythtv ivtv: Allocate DMA stream 0 using 1024 16384 byte 
buffers16777216 kbytes total
Mar 22 21:19:07 mythtv ivtv: Registered v4l2 device, streamtype 1 minor 32
Mar 22 21:19:07 mythtv ivtv: Create DMA stream 1
Mar 22 21:19:07 mythtv ivtv: Allocate DMA stream 1
Mar 22 21:19:07 mythtv ivtv: Registered v4l2 device, streamtype 2 minor 224
Mar 22 21:19:07 mythtv ivtv: Create stream 2 using 40 52224 byte 
buffers  0 kbytes total
Mar 22 21:19:07 mythtv ivtv: Allocate stream 2 using 40 52224 byte 
buffers  2097152 kbytes total
Mar 22 21:19:07 mythtv ivtv: Registered v4l2 device, streamtype 3 minor 24
Mar 22 21:19:07 mythtv ivtv: Create DMA stream 3 using 455 4608 byte 
buffers  0 kbytes total
Mar 22 21:19:07 mythtv ivtv: Allocate DMA stream 3 using 455 4608 byte 
buffers  2097152 kbytes total
Mar 22 21:19:07 mythtv ivtv: Registered v4l2 device, streamtype 4 minor 64
Mar 22 21:19:07 mythtv ivtv: Create stream 4
Mar 22 21:19:07 mythtv ivtv: Allocate stream 4
Mar 22 21:19:07 mythtv ivtv: Setting Tuner 47
Mar 22 21:19:07 mythtv tuner: type set to 47 (LG NTSC (TAPE series)) by 
ivtv i2c driver #0
Mar 22 21:19:07 mythtv saa7115: decoder set input (4)
Mar 22 21:19:07 mythtv saa7115: now setting Composite input
Mar 22 21:19:07 mythtv ivtv: Setting audio matrix to input 3, output 1
Mar 22 21:19:07 mythtv ivtv: Switching standard to NTSC.
Mar 22 21:19:07 mythtv ivtv: ivtv_enc_thread: pid = 5187, itv = 0xd88d7320
Mar 22 21:19:07 mythtv saa7115: decoder set norm NTSC
Mar 22 21:19:07 mythtv saa7115: set audio: 0x01
Mar 22 21:19:07 mythtv ivtv: Initialized WinTV PVR 250, card #0
Mar 22 21:19:07 mythtv ivtv: Autodetected WinTV PVR 150 card
Mar 22 21:19:07 mythtv ivtv: Found an iTVC16 based chip
Mar 22 21:19:07 mythtv ACPI: PCI interrupt 0000:03:08.0[A] -> GSI 9 
(level, low) -> IRQ 9
Mar 22 21:19:07 mythtv ivtv: Unreasonably low latency timer, setting to 
64 (was 32)
Mar 22 21:19:07 mythtv ivtv: XXX PCI device: 0x2530 vendor: 0x8086
Mar 22 21:19:07 mythtv tveeprom: The eeprom says no radio is present, 
but the tuner type
Mar 22 21:19:07 mythtv tveeprom: indicates otherwise. I will assume that 
radio ispresent.
Mar 22 21:19:07 mythtv tveeprom: Hauppauge: model = 23552, rev = D492, 
serial# = 7855734
Mar 22 21:19:07 mythtv tveeprom: tuner = Philips FQ1236A MK4 (idx = 92, 
type = 57)
Mar 22 21:19:07 mythtv tveeprom: tuner fmt = NTSC(M) (eeprom = 0x08, 
v4l2 = 0x00001000)
Mar 22 21:19:07 mythtv tveeprom: audio_processor = MSP3410D (type = 5)
Mar 22 21:19:07 mythtv ivtv: i2c attach [client=tveeprom[1],ok]
Mar 22 21:19:07 mythtv tuner: chip found at addr 0xc2 i2c-bus ivtv i2c 
driver #1
Mar 22 21:19:07 mythtv ivtv: i2c attach [client=(tuner unset),ok]
Mar 22 21:19:07 mythtv saa7115: starting probe for adapter ivtv i2c 
driver #1 (0x10005)
Mar 22 21:19:07 mythtv ivtv: Tuner Type 57, Tuner formats 0x00001000, 
Radio: yes,Model 0x00914652, Revision 0x00000001
Mar 22 21:19:07 mythtv ivtv: NTSC tuner detected
Mar 22 21:19:07 mythtv ivtv: Radio detected
Mar 22 21:19:07 mythtv cx25840: Ignoring new-style parameters in 
presence of obsolete ones
Mar 22 21:19:07 mythtv cx25840: FW image '/lib/modules/HcwMakoA.ROM' of 
size 13883 loaded.
Mar 22 21:19:07 mythtv cx25840: FW image md5 digest: 
a6f6a90a3be338cdb89d59e835798408
Mar 22 21:19:07 mythtv cx25840: FW image sha1 digest: 
ad2872fb98ad43b6c4afa45d239a57010edebe84
Mar 22 21:19:07 mythtv ivtv: i2c attach [client=cx25840[0],ok]
Mar 22 21:19:07 mythtv ivtv: i2c attach [client=wm8775[0],ok]
Mar 22 21:19:07 mythtv ivtv: Encoder revision: 0x02040024
Mar 22 21:19:07 mythtv ivtv: Encoder Firmware may be buggy, use version 
0x02040011
Mar 22 21:19:07 mythtv ivtv: Configuring WinTV PVR 150 card with 5 streams
Mar 22 21:19:07 mythtv ivtv: Registered v4l2 device, streamtype 0 minor 1
Mar 22 21:19:07 mythtv ivtv: Create DMA stream 0 using 1024 16384 byte 
buffers  0kbytes total
Mar 22 21:19:07 mythtv ivtv: Allocate DMA stream 0 using 1024 16384 byte 
buffers16777216 kbytes total
Mar 22 21:19:07 mythtv ivtv: Registered v4l2 device, streamtype 1 minor 33
Mar 22 21:19:07 mythtv ivtv: Create DMA stream 1
Mar 22 21:19:07 mythtv ivtv: Allocate DMA stream 1
Mar 22 21:19:07 mythtv ivtv: Registered v4l2 device, streamtype 2 minor 225
Mar 22 21:19:07 mythtv ivtv: Create stream 2 using 40 52224 byte 
buffers  0 kbytes total
Mar 22 21:19:07 mythtv ivtv: Allocate stream 2 using 40 52224 byte 
buffers  2097152 kbytes total
Mar 22 21:19:07 mythtv ivtv: Registered v4l2 device, streamtype 3 minor 25
Mar 22 21:19:07 mythtv ivtv: Create DMA stream 3 using 455 4608 byte 
buffers  0 kbytes total
Mar 22 21:19:07 mythtv ivtv: Allocate DMA stream 3 using 455 4608 byte 
buffers  2097152 kbytes total
Mar 22 21:19:07 mythtv ivtv: Registered v4l2 device, streamtype 4 minor 65
Mar 22 21:19:07 mythtv ivtv: Create stream 4
Mar 22 21:19:07 mythtv ivtv: Allocate stream 4
Mar 22 21:19:07 mythtv ivtv: Setting Tuner 57
Mar 22 21:19:07 mythtv tuner: type set to 57 (Philips FQ1236A MK4) by 
ivtv i2c driver #1
Mar 22 21:19:07 mythtv ivtv: Switching standard to NTSC.
Mar 22 21:19:07 mythtv ivtv: ivtv_enc_thread: pid = 5212, itv = 0xd88eb614
Mar 22 21:19:07 mythtv ivtv: Initialized WinTV PVR 150, card #1
Mar 22 21:19:07 mythtv ivtv: Autodetected WinTV PVR 150 card
Mar 22 21:19:07 mythtv ivtv: Found an iTVC16 based chip
Mar 22 21:19:07 mythtv ACPI: PCI interrupt 0000:03:09.0[A] -> GSI 9 
(level, low) -> IRQ 9
Mar 22 21:19:07 mythtv ivtv: Unreasonably low latency timer, setting to 
64 (was 32)
Mar 22 21:19:07 mythtv ivtv: XXX PCI device: 0x2530 vendor: 0x8086
Mar 22 21:19:07 mythtv tveeprom: The eeprom says no radio is present, 
but the tuner type
Mar 22 21:19:07 mythtv tveeprom: indicates otherwise. I will assume that 
radio ispresent.
Mar 22 21:19:07 mythtv tveeprom: Hauppauge: model = 23552, rev = D492, 
serial# = 7855734
Mar 22 21:19:07 mythtv tveeprom: tuner = Philips FQ1236A MK4 (idx = 92, 
type = 57)
Mar 22 21:19:07 mythtv tveeprom: tuner fmt = NTSC(M) (eeprom = 0x08, 
v4l2 = 0x00001000)
Mar 22 21:19:07 mythtv tveeprom: audio_processor = MSP3410D (type = 5)
Mar 22 21:19:07 mythtv ivtv: i2c attach [client=tveeprom[2],ok]
Mar 22 21:19:07 mythtv tuner: chip found at addr 0xc2 i2c-bus ivtv i2c 
driver #2
Mar 22 21:19:07 mythtv ivtv: i2c attach [client=(tuner unset),ok]
Mar 22 21:19:07 mythtv saa7115: starting probe for adapter ivtv i2c 
driver #2 (0x10005)
Mar 22 21:19:07 mythtv cx25840: FW image '/lib/modules/HcwMakoA.ROM' of 
size 13883 loaded.
Mar 22 21:19:07 mythtv cx25840: FW image md5 digest: 
a6f6a90a3be338cdb89d59e835798408
Mar 22 21:19:07 mythtv cx25840: FW image sha1 digest: 
ad2872fb98ad43b6c4afa45d239a57010edebe84
Mar 22 21:19:07 mythtv ivtv: i2c attach [client=cx25840[1],ok]
Mar 22 21:19:07 mythtv ivtv: i2c attach [client=wm8775[1],ok]
Mar 22 21:19:07 mythtv ivtv: Tuner Type 57, Tuner formats 0x00001000, 
Radio: yes,Model 0x00914652, Revision 0x00000001
Mar 22 21:19:07 mythtv ivtv: NTSC tuner detected
Mar 22 21:19:07 mythtv ivtv: Radio detected
Mar 22 21:19:07 mythtv ivtv: Encoder revision: 0x02040024
Mar 22 21:19:07 mythtv ivtv: Encoder Firmware may be buggy, use version 
0x02040011
Mar 22 21:19:07 mythtv ivtv: Configuring WinTV PVR 150 card with 5 streams
Mar 22 21:19:07 mythtv ivtv: Registered v4l2 device, streamtype 0 minor 2
Mar 22 21:19:07 mythtv ivtv: Create DMA stream 0 using 1024 16384 byte 
buffers  0kbytes total
Mar 22 21:19:07 mythtv ivtv: Allocate DMA stream 0 using 1024 16384 byte 
buffers16777216 kbytes total
Mar 22 21:19:07 mythtv ivtv: Registered v4l2 device, streamtype 1 minor 34
Mar 22 21:19:07 mythtv ivtv: Create DMA stream 1
Mar 22 21:19:07 mythtv ivtv: Allocate DMA stream 1
Mar 22 21:19:07 mythtv ivtv: Registered v4l2 device, streamtype 2 minor 226
Mar 22 21:19:07 mythtv ivtv: Create stream 2 using 40 52224 byte 
buffers  0 kbytes total
Mar 22 21:19:07 mythtv ivtv: Allocate stream 2 using 40 52224 byte 
buffers  2097152 kbytes total
Mar 22 21:19:07 mythtv ivtv: Registered v4l2 device, streamtype 3 minor 26
Mar 22 21:19:07 mythtv ivtv: Create DMA stream 3 using 455 4608 byte 
buffers  0 kbytes total
Mar 22 21:19:07 mythtv ivtv: Allocate DMA stream 3 using 455 4608 byte 
buffers  2097152 kbytes total
Mar 22 21:19:07 mythtv ivtv: Registered v4l2 device, streamtype 4 minor 66
Mar 22 21:19:07 mythtv ivtv: Create stream 4
Mar 22 21:19:07 mythtv ivtv: Allocate stream 4
Mar 22 21:19:07 mythtv ivtv: Setting Tuner 57
Mar 22 21:19:07 mythtv tuner: type set to 57 (Philips FQ1236A MK4) by 
ivtv i2c driver #2
Mar 22 21:19:07 mythtv ivtv: Switching standard to NTSC.
Mar 22 21:19:07 mythtv ivtv: Initialized WinTV PVR 150, card #2
Mar 22 21:19:07 mythtv ivtv: ====================  END INIT IVTV  
====================









More information about the mythtv-users mailing list