[mythtv-users] Mythtv frontend directly to framebuffer (without X)?

Aurelien Marchand aurelien.marchand at researchcapital.com
Tue May 24 13:44:33 UTC 2005


Hi all,

I've gone through the last 5 months of archive but I can't find a 
reference to my question #1. I guess I should describe my setup first:

a) I have compiled and installed MythTV (despite the random segfault issues with gcc).
b) I use my 2.4 GHz Celeron as a backend. I have a WinTV card 
that works great to watch TV (I used tvtime to watch tv on it) and I 
have enough disk space for my (current) needs.
c) I want to use my T20 thinkpad laptop (its screen is dead, but I 
have an LCD attached to it and an S-video port out) as a frontend. It is 
a 750 MHz with 192 MB of RAM. I have used it to watch DVDs under X when 
I used XFree's X server but now that I use Xorg's X server, the XV 
extension doesn't work (even though it says in my log that it loaded 
fine). I am thus forced to use the framebuffer directly to have decent 
speed when I playback a DVD. (if you need to know, if I play a DVD on my 
X session, I have a blue window where the video should appear in).
d) I'm running Mandrake 10.1 PowerPack+ on all my machines.

Anyways, so here goes my questions (my apologies if I'm beating a dead cat):

1) Is it possible to have Myth Frontend directly on the framebuffer, 
instead of using X (to bypass my XV pb)? Mplayer was able to write to 
the framebuffer with no issues and since MythTV uses xine or mplayer to 
play movies I thought there might be a chance it would work.
2) my brother uses XP MCE and it was able to play from his music store 
while browsing his digital pictures. Is MythTV able to do the same, or 
is it a "one activity at a time" kind of thing?
3) when I want to rip up a CD or a DVD, should I insert it in the 
backend or the frontend? If I want to play a DVD, I would prefer be able 
to do on the frontend, but playing is different than ripping.
4) a more technical question: I registered to labs.zap2it.com but mythtv-setup cannot download data from their webservice portal. Is there any trick to make it work?

Thanks to all who will respond. I have search on the net for the info 
but it did not answer my questions as well as you certainly would.

Aurelien




More information about the mythtv-users mailing list