[mythtv-users] mythtranscode silently dies

Andrew McNabb amcnabb at mcnabbs.org
Sun Oct 2 16:14:26 UTC 2005


On Sat, Oct 01, 2005 at 08:17:38PM -0400, Chris Pinkham wrote:
> 
> If you are on the recording backend, then this should work unless your
> hostname is messed up for these recordings like if you changed the
> hostname on the machine.  If you mounted the recordings directory on
> the machine you are trying to run mythtranscode on, then make sure
> that you mounted it on the same directory it exists on on the backend
> that made the recording.
> 

That's it.  The hostname on the backend changed a while back.  The crazy
thing is that the change didn't do anything to normal playback, or I
would have been aware of the problem from the start.  Oh, well.
Everything's great now.

Since it took some work to get error messages, I'd like to leave some
tips for future archive-searchers who have the problem.  Once again, the
part of the error that you see is that nuvexport gives you:

Waiting for mythtranscode to set up the fifos.
(Repeats this message at least 27 more times)
Waiting for mythtranscode to set up the fifos.
Waited too long for mythtranscode to create its fifos. Please try again.

What you need to do is run "nuvexport --debug" which will tell it to
print out the full command for mythtranscode it will execute.  Run this
command, but get rid of the "2>&1" and add "-v all" to make it verbose.

This should at least give you somewhere to start.

Thanks again to everyone who helped.

-- 
Andrew McNabb
http://www.mcnabbs.org/andrew/
PGP Fingerprint: 8A17 B57C 6879 1863 DE55  8012 AB4D 6098 8826 6868
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 186 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20051002/42c8e67e/attachment.pgp


More information about the mythtv-users mailing list