[mythtv-users] Mythwelcome sometimes won't shutdown

Hansa mythtv at logic-q.nl
Wed Aug 16 14:01:54 UTC 2006


So if I understand it correctly, the problem can be solved (temporarily) by
adding a cron job which sets all previous scheduled jobs to 'do not record'
?

  -----Oorspronkelijk bericht-----
  Van: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org]Namens Brian Steele
  Verzonden: woensdag 16 augustus 2006 6:22
  Aan: Discussion about mythtv
  Onderwerp: Re: [mythtv-users] Mythwelcome sometimes won't shutdown





  On 8/15/06, Calvin Harrigan <charriglists at bellsouth.net> wrote:
    Brian Steele wrote:

    I'm not sure if the bug is in mythwelcome or not.  I used to use my own
    program similar to mythwelcome that got the upcoming recordings
    information from mythbackend and it exhibited the same problem.  Even
    worst my program would be called from mythbackend during startup with
    the parameter of wheter or not the system woke up for a recording or
    manual power up.  I think the parameter was "user" or "auto".  If I
    powered on the system manually during the time that a recording was
    scheduled, though disabled for whatever reason it would indicate that
    the system is in automode, thus my program would never start the
    frontend, then the system would shutdown because a frontend didn't
    connect in the alloted time.  I know I could work around this by
    blocking shutdown before the connection of the backend, but that would
    hamper some other personalized settings on the system.  I had hoped that
    this would have been fixed in 0.19, because of the inclusion of
    mythwelcome, but alas it wasn't.  I've brought it up before, but it
    didn't get any traction.  Maybe this time?  Just my $.02


  I think you're right, this is most likely a bug in mythbackend.  I
actually tried to fix the problem you are talking about in 0.18 when I
changed the code on my machine to avoid shutdown when there were user jobs
pending but I didn't spend enough time to do it right.  Maybe I'll take
another crack at it and see if I can't get a patch included in 0.20.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20060816/c0102994/attachment.htm 


More information about the mythtv-users mailing list