[mythtv-users] SMP Performance

Brad DerManouelian myth at dermanouelian.com
Mon Dec 11 06:26:44 UTC 2006


On Dec 10, 2006, at 10:10 PM, Greg Grotsky wrote:

> On 12/10/06, Brad DerManouelian <myth at dermanouelian.com> wrote:
> On Dec 10, 2006, at 1:37 PM, Greg Grotsky wrote:
> I just upgraded my system to a new kernel (2.6.18-1.2239.fc5) and  
> new nvidia drivers (9631). kernel deinterlace gives me 105% on  
> mythfronend and 25% on xorg. linear deinterlace is the same as it  
> was before. This is the reason I ended up upgrade my AMD 64 3200+  
> system. I was tired of trouble-shooting XvMC and OpenGL settings to  
> get something that worked. Now it works, just chews up all my CPU.  
> I am using an nVidia 6600-OC card. It's PCI-Express. I just kept  
> throwing money at the machine until I could watch HD without  
> stuttering. My time was worth more to me than the cash I was  
> spending on it. This is also the reason I don't run svn. I get too  
> frustrated when things break so I'm using up to date .20 from ATrpms.
>
> Geesus!  It sounds like your system should be kickin'-fast, you  
> should be able to do picture-in-picture with two 1080i streams!   
> You really don't need two cores to do a single HD stream... maybe  
> the problem is FC, but then, I've always had a distaste for Red  
> Hat.  Have you tried another distro?  That does sound like a lot of  
> money.  What motherboard, what kind of memory, how fast, how much?   
> Those items and possibly the OS is really all that seems to stand  
> in your way to speed.  I'm using a MSI Neo2 Platinum the one with  
> NForce3 Ultra chipset, I have a gig of micron low latency DDR.

It's an Asus A8N-SLI motherboard with 1.5GB of PC-3200 memory. Never  
tried another distro.

> Did you check to see if your using NvAGP?  That could be killing  
> you too.  I think there are only certain chipsets that support it  
> so check the doc first.  But to get it working if it's not, put  
> agp=off in your boot string and put NvAGP=1 in your xorg.conf.   
> Then when X loads, if possible, you'll be running with NvAGP.

I'll give that a try on my next reboot and see how it goes.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20061210/c230558b/attachment.htm 


More information about the mythtv-users mailing list