[mythtv-users] IVTV PVR 350 TV Out - ivtvdev_drv.o is unresolved

scott at tbwifi.ca scott at tbwifi.ca
Mon Dec 11 21:38:50 UTC 2006


I am trying to get TV out working on a PVR 350 on a Mandriva 2006 distro. 
I am having the same X errors as are shown in a referenced discussion
below.  My hunting around suggests that many others have stumbled on the
same issue.  My question for the people who have managed to solve this is
just what they did to get up and running.  Andy references a Hellion link
http://www.hellion.org.uk/ivtv/index.html, which seems geared to Debian,
but others have suggested that the resolution is Distro independent.  The
X Driver link is http://www.hellion.org.uk/ivtv/index.html.  The errors
shown below refer to the ivtvdev_drv.o file.  The file in the link is
ivtvdev_drv.so~i386.  Does one just rename it to suit or am I missing
something more?

Andy’s post…

Thursday, 20 July 2006
MythTV: Finally I could move the UI to the Hauppauge TV Out
One of the annoying thing on my frontend box was that I had to switch on
the TV between two input channels because the video cards S-Video output
had to be on another input channel than the Hauppauge TV Tuner card's TV
Out. After a while I figured out that one can display the X window output
onto the TV Tuner's TV Out but I could not figure out how it works. After
a while I finally found a fairly good description on Wikibooks MythTV
Installation description (2/3 down the page). After fiddling around with X
I finally could make it work, nearly. It failed at the very end with an
exception that the IVTV X driver contained some missing symbols:
Required symbol shadowAdd from
module/usr/X11R6/lib/modules/drivers/ivtvdev_drv.o is unresolved!
Required symbol shadowSetup from
module/usr/X11R6/lib/modules/drivers/ivtvdev_drv.o is unresolved!
Required symbol fbPictureInit from
module/usr/X11R6/lib/modules/drivers/ivtvdev_drv.o is unresolved!
Required symbol fbScreenInit from
module/usr/X11R6/lib/modules/drivers/ivtvdev_drv.o is unresolved!
Required symbol shadowAlloc from
module/usr/X11R6/lib/modules/drivers/ivtvdev_drv.o is unresolved!
and after posting an email to the IVTV mailing list with no feedback I was
stuck.
Somehow searching around the net I stumbled over this page:
http://www.hellion.org.uk/ivtv/index.html which contained a updated
driver. Nevertheless the page was dealing with Debian Linux and so I was
skeptical. But you do not know until you tried and so I downloaded and
installed the new driver. After rebooting the box I finally could bring up
X on the TV out channel and now I do not have to switch the TV input
channels anymore.
The last item on my list is to hide all the Linux bootstrap output behind
a splash screen to make it look neat and tidy.
Have fun - Andy
Posted by schaefera at 7:24 PM in Linux



More information about the mythtv-users mailing list