[mythtv-users] mythtv hard lockup

R. G. Newbury newbury at mandamus.org
Thu Dec 21 02:08:26 UTC 2006


Yeechang Lee wrote:
> David Rees <drees76 at gmail.com> says:
>> My system does similar (FC5, Nvidia 9742 and previously 8776, ivtv
>> 0.8.2 w/2 PVR-250s, latest mythtv from atrpms). It's been locking up
>> for a while. When my system locks up, the computer responds to
>> network commands (ping, can start a ssh session but never get a
>> prompt), but it seems that any disk IO gets stuck as I can't get a
>> shell. Seems to happen once a week or so.
> 
> These exact symptoms started happening to me a month or two ago on my
> Pentium 4 3.0GHz Fedora Core 4 dedicated frontend+backend after almost
> a year of reliable service. Same symptoms as yours; I'd advise you to
> try logging into a console session ahead of time and then, at the next
> crash, switching to it to see if you can a) do local-disk reads (by,
> say, 'ls -la /'),

Ohh you are whining about *nothing*!  When MY frontend crashes, MY 
lockup is worse than yours!!

Seriously, you are lucky that you can switch to a console. When mine 
goes out, the keyboard is totally unresponsive and I cannot switch to a 
console..

I am using a Via motherboard... which suggests that:

a)	there are a number of different lockup triggers..as the nvidia driver 
cannot be causing my lockup...unless it is within the common portions of 
the openchrome driver (I understand the nvidia driver has common code) 
or its in X (drm, dri etc.)
or
b)	it is something withing Mythtv, probably a race condition, which 
might be related to lirc or affected by lirc. I discount ivtv as all of 
my lockups occur during playback.

Geoff
	


More information about the mythtv-users mailing list