[mythtv-users] XvMC Problem and Question

Brian Wood beww at beww.org
Fri Feb 10 17:01:09 UTC 2006


On Feb 10, 2006, at 8:59 AM, SÚrgio Gaspar wrote:

>>
>> Much thanks for the reply. I tried your suggestion, uninstalling with
>> the installer and unmerging the 7676 drivers, basically starting
>> completely from scratch and re-loading 7676 and myth.
>>
>> FWIW this is an amd64 3700 running Gentoo 2.6.15
>>
>> I still get (when trying to use XvMC):
>>
>> Using XvMC version 1.0
>> XvMC found and using IDCT surface
>> Using xv port 240
>> Unable to create XvMC context return status 11 BadAlloc
>>
>> Other than this things work OK.
>>
>> So, I am running out of ideas, but I have one more:
>>
>> I'm using both the VGA and the composite output, driving a 14" LCD
>> (vga) and a 32" LCD (via composite). Is there a problem using XvMC
>> while driving two outputs. I've gone through the nVidia README and
>> haven't seen a prohibition against that but it does allude to some
>> limitations.
>>
>> Thanks again.
>>
>
> Well, I'm also running myth on an amd64 (3000+ Venice core) and I  
> can't
> get XvMC to work. Some time ago I asked for help on this list and  
> someone
> told me that it was a  problem with the nvidia driver on 64bit  
> machines,
> so I gave up.
>
> I don't read all messages on this list but since then I have never  
> read a
> success story regarding XvMC on AMD64 using Geforce FX 5200 or better
> nvidia cards.
>
> The result is that I can use the PiP function and have colour OSD,  
> and I
> know  that the PiP doesn't work and OSD is B&W while using XvMC  
> (had XvMC
> working on an Athlon XP). The only anoyance for me regarding not using
> XvMC is that the CPU cooler runs faster and it's the noisiest fan  
> on my
> system.
>
> On the old Athlon XP I was able to use XvMC on the TVout, the VGA  
> output
> was still active at a different resolution but I don't remember if  
> XvMC
> was working there too. This means you can have two outputs and that  
> won't
> stop you from using XvMC at least on one of them.
>
> Good luck.
>

Well it wouldn't be the first time I've spent hours trying to make  
something work that "shouldn't".

The amd64 seems to be a very popular CPU from what I've seen on this  
list, although I don't know how many users are running 64-bit, as  
opposed to 32-bit MythTV installations (knoppmyth?) on them. The  
nVidia cards also seem quite popular for MythTV installations. I  
would think that a limitation on XvMC on this combination would be  
well-known, but OTOH these CPUS are fast enough that maybe folks just  
don't use it?

I don't really *need* XvMC, and from the limitations you mentioned it  
sounds like I wouldn't use it even if I get it working, but you know  
how it is -- it just "bugs" me when something doesn't work :-)

If anyone can confirm that XvMC will not work on an amd64 in 64-bit  
mode it would be nice, conversely if anyone has it working I'd be  
interested as well. I'll try and ask nVidia directly, but it seems  
they make it hard to actually ask a question, I think you have to  
"register your product" before you can do so, and their  
"knowledgebase" seems to consist of the (admittedly pretty good)  
README file :-((


More information about the mythtv-users mailing list