[mythtv-users] More popup menu oddities (can't select / wrong

Chris Pinkham cpinkham at bc2va.org
Fri Jan 27 05:54:50 UTC 2006


> On 1/26/06, Justin Hornsby <justin.hornsby at gmail.com> wrote:
> >Screenshots would help me a lot :-)
> 
> <http://wendy.seltzer.org/mythtv/bad-popup.png> nothing selected or
> selectable, blue buttons
> 
> <http://wendy.seltzer.org/mythtv/good-popup.png> same screen, now it
> selects, and the buttons are gray
> (after starting the program and fast-forwarding to the end a second time)

Are you sure these aren't focus issues?  When I run mythfrontend on my
dev box and I move the mouse outside of the mythfrontend window, I see
something exactly like what you're describing, the colors change and
no button is highlited (since none of them have focus).

On my production system, I have been bothered by a "bug" for a long time
where a popup would come up and the proper button would be highlighted,
but occasionally another button would be a 3rd color different than the
highlighted and non-highlighted buttons.  One day it hit me that this
oddball button was under the invisible mouse pointer.  When I moved the
mouse outside of the popup area, the 3rd-colored button changed to
the non-highlighted color.  Now I try to keep my mouse at the edge of
the screen, but when the frontend restarts, X puts the mouse in the
middle of the screen and I have to move the mouse otherwise an
occasional popup will have this odd-colored button.

-- 
Chris



More information about the mythtv-users mailing list