[mythtv-users] Xine or Mplayer with files of any type (mpeg, avi etc) no sound

Allan Wilson allanwilson at gmail.com
Mon Jun 12 11:38:32 UTC 2006


On 6/12/06, Francesco Peeters <Francesco at fampeeters.com> wrote:
>
> On Mon, June 12, 2006 8:19, Doug said:
> > I am trying to get my media library to work with Xine or mplayer via :
> > mplayer -fs -ao alsa:mmap:noblock:device=hw=0.4 %s
> > or
> > xine -p %s
> > or
> > mplayer -fs %s
> >
> > They all find my spdif port as 0,4 ( which works for mp3's and dvd's via
> > myth and xine or mplayer as DVD player)
> >  but wont play a single file with audio,  but the video is fine?
> >
> > How do I get the audio to play is the a command line issue?  an spdif
> > passthrough issue?
> >
> A few questions that may help paint a clearer picture to help solving
> this:
>
> What type of audio stream is in the video files? MP3/OGG/AC/???
>
> Have you tried video files with other audio formats? If so, did you get
> the same results?
> Have you successfully played audio-only files in the same format?
>
> What is your audio setup? (OK, It's ALSA, but what H/W, etc.)
>
> Good luck!
>
> --
> Francesco Peeters
> ----
> GPG Key > If your program doesn't recognize my signature, please visit
> http://www.CAcert.org/index.php?id=3 to retrieve the Root CA certificate.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>

Not sure if this is your problem but this fixed a problem I was having. From
an earlier post:

Correct, I was assuming English and we all know about assuming. You can run
mplayer -v filename to see what languages that the rip supports. If it is
something other than 128 the you place a config file in that users .mplayer
directory located in their home directory. For most people this will be:

     ~/.mplayer/movietitle.ext.conf

So if you are trying to fix a language problem for a movie such as Bad Boys
II, which is one that will not work correctly then you rip it and then run:

     mplayer -v The\ Matrix.vob

The will show something like this about 10% down in the output:

     found audio track 0
     found audio track 129
     found audio track 128

In this case since 129, french, is the first on in the list it defaults to
that unless you specify 128 for english. So by adding the line

     aid8

to the mplayer config file located on most systems at

     /etc/mplayer/mplayer.conf

It will default to 128 instead of 129. I had on movie that I was backing up
that used 1 instead of 128, Reindeer Games. So to fix it on a movie by movie
basis change in to your users home directory and then go in to the .mplayer
directory. For most people this will be:

     cd ~/.mplayer/

Once their you will create a custom config file for just that movie by
creating a file with the full filename of the movie including the extension
and adding config to the end. So for Reindeer Games it ended up being:

     Reindeer_Games.avi.conf

Inside of that file you just need one line that says

     aid=1

Allan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20060612/302e6fa9/attachment.htm 


More information about the mythtv-users mailing list