[mythtv-users] Long wait time for connection from mythfrontend to mythbackend and mythfrontend's confusion about database entries

Michael Sullivan michael at espersunited.com
Mon Jun 19 14:46:51 UTC 2006


I got my MythTV setup working yesterday, or at least better than it's
working now.  Last night I told it to record a movie that was on, and
then to record several things in the future.  I look in /mnt/store and
my movie is there, however, when I go to Media Library and the Select
Group Filter pops up, it suggests to me that there is one program
recorded.  However, when I select to see that one program, it insists
that nothing has been recorded.  Furthermore, when I go Upcoming
Recordings (I entered several last night) it insists that nothing has
been set to record.  However, when I open the mythconverg database in
mysql and and select * from oldrecorded, I see data there, and not just
my movie from last night, but a couple of shows that I thought I'd
marked not to be recorded.  Why can't Myth see the mythconverg database?
In mythfrontend, the listings are all there.  What's going wrong here?

Also, in the below output:

michael at camille ~ $ mythfrontend
2006-06-19 09:31:34.787 Using runtime prefix = /usr
2006-06-19 09:31:35.095 XScreenSaver support enabled
2006-06-19 09:31:35.323 New DB connection, total: 1
2006-06-19 09:31:35.676 Connected to database 'mythconverg' at host:
localhost
2006-06-19 09:31:35.678 Total desktop dim: 1024x768, with 1 screen[s].
2006-06-19 09:31:35.687 Using screen 0, 1024x768 at 0,0
2006-06-19 09:31:35.703 Current Schema Version: 1123
2006-06-19 09:31:35.703 mythfrontend version: 0.19.20060121-2
www.mythtv.org
2006-06-19 09:31:35.703 Enabled verbose msgs:  important general
2006-06-19 09:31:36.389 lang0: eng
2006-06-19 09:31:36.390 lang: eng
2006-06-19 09:31:36.420 lang1: eng
2006-06-19 09:31:36.420 lang: eng
2006-06-19 09:31:36.601 Total desktop dim: 1024x768, with 1 screen[s].
2006-06-19 09:31:36.707 Using screen 0, 1024x768 at 0,0
2006-06-19 09:31:36.715 Switching to square mode (G.A.N.T.)
mythtv: could not connect to socket
mythtv: No such file or directory
lirc_init failed for mythtv, see preceding messages
2006-06-19 09:31:38.088 Joystick disabled.
2006-06-19 09:31:38.342 Registering Internal as a media playback plugin.
2006-06-19 09:32:26.004 Connecting to backend server: 192.168.1.3:6543
(try 1 of 5)
2006-06-19 09:32:46.005 ReadStringList timeout (quick).
2006-06-19 09:32:46.005 Unexpected response to MYTH_PROTO_VERSION:
2006-06-19 09:32:46.005 ProgramList::FromScheduler(): Error querying
master.
2006-06-19 09:32:58.681 Connecting to backend server: 192.168.1.3:6543
(try 1 of 5)
2006-06-19 09:33:18.685 ReadStringList timeout (quick).
2006-06-19 09:33:18.685 Unexpected response to MYTH_PROTO_VERSION:
2006-06-19 09:33:18.685 ProgramList::FromScheduler(): Error querying
master.
2006-06-19 09:33:25.331 Connecting to backend server: 192.168.1.3:6543
(try 1 of 5)

michael at camille ~ $

As you can see from the time stamps, there's quite a long time gap every
time mythfrontend has to connect to mythbackend.  This happens every
time I ask to view a listing, or the Media Library/Upcoming
Recordings/Delete recordings.  The database is on my local machine,
along with mythbackend and mythfrontend.  Why is it taking so long?
BTW, I'm using mythtv-0.19_p9163-r1 on a Gentoo system with kernel
2.6.15-gentoo-r1.  Thanks in advance for your help.
-Michael Sullivan-



More information about the mythtv-users mailing list