[mythtv-users] Tuning QAM for Charter Cable with HD3000

Mark Johannessen mfjlaw at gmail.com
Fri Mar 31 05:36:57 UTC 2006


On a system using a PRV-350 and a HD3000 with Charter cable as inputs
to each card (using a simple splitter from the outside feed):

Using atscscan per the Adding QAM Channels for HDTV Tuner Cards wiki,
on Charter cable I get about 50 entries like this (I've renumbered the
left most column and set the VID to the AID less 1 per the wiki) using
us-Cable-Standard-center-frequencies-QAM256:

0001:573000000:QAM_256:1031:1639:7
0002:573000000:QAM_256:1026:1027:6
0003:573000000:QAM_256:1021:1022:5
0004:573000000:QAM_256:1001:1002:1
0005:573000000:QAM_256:1036:1037:8
0006:573000000:QAM_256:1011:1012:3
0007:573000000:QAM_256:1016:1017:4
0008:573000000:QAM_256:1006:1007:2
0009:621000000:QAM_256:272:273:5
0010:621000000:QAM_256:80:81:3
0011:621000000:QAM_256:144:145:2
0012:621000000:QAM_256:208:209:4
0013:621000000:QAM_256:16:17:1
0014:621000000:QAM_256:395:401:7
...

Using azap, I can get a "FE_HAS_LOCK" on all of the channels. In
another terminal I run mplayer /dev/dvb/adapter0/dvr0 and only 4-5
channels play anything (although the video is jerky and the audio
studders and cracks which is a reported problem with mplayer playing
an HD stream).  The other channels don't play at all with output like
this:

=========================
$ mplayer -v -ao alsa /dev/dvb/adapter0/dvr0
MPlayer 1.0pre7try2-3.2.3 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices  (Family: 8, Stepping: 2)
Detected cache-line size is 64 bytes
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 1
CommandLine: '-v' '-ao' 'alsa' '/dev/dvb/adapter0/dvr0'
init_freetype
get_path('font/font.desc') -> '/home/mythtv/.mplayer/font/font.desc'
font: can't open file: /home/mythtv/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your
system startup scripts.
Using nanosleep() timing
get_path('input.conf') -> '/home/mythtv/.mplayer/input.conf'
Can't open input config file /home/mythtv/.mplayer/input.conf: No such
file or directory
Can't open input config file /etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such file or directory
Can't init input joystick
Setting up LIRC support...
get_path('dvr0.conf') -> '/home/mythtv/.mplayer/dvr0.conf'
Playing /dev/dvb/adapter0/dvr0.
[file] File size is 0 bytes
STREAM: [file] /dev/dvb/adapter0/dvr0
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for Nullsoft Streaming Video
Checking for NuppelVideo
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename /dev/dvb/adapter0/dvr0 ext: (null)
Checking for MOV
Checking for VIVO
header block 1 size: 3
AVS: avs_check_file - attempting to open file /dev/dvb/adapter0/dvr0
Win32 LoadLibrary failed to load: avisynth.dll,
/usr/lib/win32/avisynth.dll, /usr/local/lib/win32/avisynth.dll
AVS: failed to load avisynth.dll
AVS: Init failed
Checking for PVA
Checking for MPEG-TS...
TRIED UP TO POSITION 40, FOUND 47, packet_size= 188, SEEMS A TS? 1
GOOD CC: 32, BAD CC: 0
TS file format detected.
DEMUX OPEN, AUDIO_ID: -1, VIDEO_ID: -1, SUBTITLE_ID: -1,
Checking for MPEG-TS...
TRIED UP TO POSITION 19860, FOUND 47, packet_size= 188, SEEMS A TS? 1
GOOD CC: 32, BAD CC: 0
PROBING UP TO 2000000, PROG: 0
NO VIDEO! NO AUDIO!  NO SUBS (yet)!
Opened TS demuxer, audio: ffffffff(pid -1), video: ffffffff(pid -1)...POS=0
No stream found.
vo: x11 uninit called but X11 not inited..
Exiting... (End of file)
===============================

If I use an antenna as the video source, I get the same channels
(which are local over the air broadcasts).

I can receive a number of HD channels through the cable box.

My question is, when an atscscan scan is performed using one of the
QAM file descriptions, should it be picking up all of the HD channels
I recieve via my cable service, or are some channels inaccessible to
the scan/HD3000 due to encryption or some format issue? It appears the
atscscan resulting list either does not pick up a bunch of channels I
know I receive via cable (such as HBO HD), or one of the entries could
be HBO HD but mplayer can't play it.  I was intending on using the
mythtv box mostly to record HD broadcasts and it will suck if all I
can record are the local over the air HD channels.

On a similar note on how different formats are captured in a mythtv
system, in my local channel zap2it lineup for local antenna
broadcasts, I have both regular broadcasts and digital broadcasts like
this:

10 KXTV
10-1 KXTVDT
10-2 KXTVDT2

Would the PVR-350 be used to capture KXTV, and the HD3000 to capture
KXTVDT and KXTVDT2 (though not HD, still they are digital), or would
the PVR-350 be used to also capture the digital channels KXTVDT and
KXTVDT2 and the HD3000 strictly for HD broadcasts?

Mark


More information about the mythtv-users mailing list