[mythtv-users] OT: Upgrade to Mysql 5.0

David Rees drees76 at gmail.com
Mon May 1 22:55:25 UTC 2006


On 5/1/06, Sam Varshavchik <mrsam at courier-mta.com> wrote:
> > Douglas Wagner wrote:
> > Unfortunately mysql is not, to my knowledge, available through yum. I
> > got the upgrade to work however, by using 'rpm --force -U MySQL'.
>
> Never use --force, unless it's just a temporary workaround for a known, and
> fully understood packaging error, which will quickly be rectified by an
> upgrade to a later package release, which will not use --force.
>
> Your updated mysql package will probably fail in some subtle way at some
> point, or, worse yet, continue to work but give incorrect results.  Or,
> other software that has an explicit dependency on your older version of
> MySQL will malfunction or lose stability, in some way.

In this case, it's not MySQL that is going to break, it's all the
other packages that were depending on his old version of MySQL. This
type of thing by one or more of the following:

1. Uninstall RPMs which depend on the old packages. This is a good
idea if you know you aren't using RPMs which depend on the package you
are upgrading.
2. Install compatibility packages. MySQL has shared compatibility
packages just for this reason.
3. Stay with the old version of software. Unless you have a specific
reason to upgrade, it's easier to just stick with the current version.
Why upgrade when the old one works just fine?

-Dave


More information about the mythtv-users mailing list