[mythtv-users] MythTV and ivtv upgrade, no more live TV

Michael A Weber mweberjunk01 at wowway.com
Wed May 17 12:27:30 UTC 2006


Today I decided to upgrade my ivtv driver, which led to a kernel update as
well.  I have successfully updated the kernel (2.6.16-1.2108_FC4), video
driver (nvidia 8756), ivtv driver (0.6.2?), and MythTV to 0.19 build 128.

 

I have tested capture with my PVR-500 card, playing it back through xine and
that's functioning normally (and with MUCH better audio than I had
previously, which was the whole goal for the ivtv upgrade).

 

However, when I try to launch Live TV from within MythTV, I get a blank
screen for about 15 seconds, and then it goes back to the main menu,
apparently doing nothing.

 

I have checked the backend log, and this is what I find:

 

2006-05-15 01:40:12.602 MainServer::HandleAnnounce Playback

2006-05-15 01:40:12.617 adding: mythtv.mikeywebs.com as a client (events: 0)

2006-05-15 01:40:12.630 TVRec(2): Changing from None to WatchingLiveTV

select timeout - ivtv driver has stopped responding

2006-05-15 01:40:20.153 TVRec(2): Changing from WatchingLiveTV to None

select timeout - ivtv driver has stopped responding

2006-05-15 01:40:25.139 Finished recording The Great Cake-Off: channel 1037

 

I previously got an error about going to TV Settings and setting up the
software encoders in Recording Profiles, which eliminated part of this
message.  I since have deleted all capture cards, set them back up, set all
the recording profiles, and I'm getting this select timeout on the ivtv
driver.

 

Can anyone provide any information or point me in the right direction as to
what I need to do to get this working again?  I don't get to watch much TV,
but what I do I have been recording and watching at a convenient time
(without commercials to boot!), and now I'm spoiled.  :-(

 

TIA,

 

Mike

 

My DMesg output for the ivtv driver looks good, too, and is as follows:

 

ivtv:  ========== START INIT IVTV ==========

ivtv:  version 0.6.2 (development snapshot compiled on Mon May  8 07:44:41
2006) loading

ivtv:  Linux version: 2.6.16-1.2108_FC4 686 REGPARM 4KSTACKS gcc-4.0

ivtv:  In case of problems please include the debug info between

ivtv:  the START INIT IVTV and END INIT IVTV lines, along with

ivtv:  any module options, when mailing the ivtv-users mailinglist.

ivtv0: Autodetected Hauppauge WinTV PVR-150 card (cx23416 based)

tveeprom 1-0050: Hauppauge model 23552, rev D292, serial# 7721725

tveeprom 1-0050: tuner model is Philips FQ1236A MK4 (idx 92, type 57)

tveeprom 1-0050: TV standards NTSC(M) (eeprom 0x08)

tveeprom 1-0050: second tuner model is Philips TEA5768HL FM Radio (idx 101,
type 62)

tveeprom 1-0050: audio processor is CX25843 (idx 37)

tveeprom 1-0050: decoder processor is CX25843 (idx 30)

tveeprom 1-0050: has radio, has no IR remote

ivtv0: This is the first unit of a PVR500

tuner 1-0060: TEA5767 detected.

tuner 1-0060: chip found @ 0xc0 (ivtv i2c driver #0)

tuner 1-0060: type set to 62 (Philips TEA5767HN FM Radio)

tuner 1-0061: chip found @ 0xc2 (ivtv i2c driver #0)

tda9887 1-0043: chip found @ 0x86 (ivtv i2c driver #0)

cx25840 1-0044: cx25843-23 found @ 0x88 (ivtv i2c driver #0)

cx25840 1-0044: loaded v4l-cx25840.fw firmware (13353 bytes)

wm8775 1-001b: chip found @ 0x36 (ivtv i2c driver #0)

ivtv0: loaded v4l-cx2341x-enc.fw firmware (262144 bytes)

ivtv0: Encoder revision: 0x02050032

ivtv0: Allocate DMA encoder MPEG stream: 128 x 32768 buffers (4096KB total)

ivtv0: Allocate DMA encoder YUV stream: 194 x 10800 buffers (2048KB total)

ivtv0: Allocate DMA encoder VBI stream: 120 x 17472 buffers (2048KB total)

ivtv0: Allocate DMA encoder PCM audio stream: 455 x 4608 buffers (2048KB
total)

ivtv0: Create encoder radio stream

tuner 1-0061: type set to 57 (Philips FQ1236A MK4)

ivtv0: Initialized WinTV PVR 500 (unit #1), card #0

ivtv:  ===========  NEXT CARD  ===========

ivtv1: Autodetected Hauppauge WinTV PVR-150 card (cx23416 based)

tuner 2-0061: chip found @ 0xc2 (ivtv i2c driver #1)

tda9887 2-0043: chip found @ 0x86 (ivtv i2c driver #1)

cx25840 2-0044: cx25843-23 found @ 0x88 (ivtv i2c driver #1)

cx25840 2-0044: loaded v4l-cx25840.fw firmware (13353 bytes)

wm8775 2-001b: chip found @ 0x36 (ivtv i2c driver #1)

tveeprom 2-0050: Hauppauge model 23552, rev D292, serial# 7721725

tveeprom 2-0050: tuner model is Philips FQ1236A MK4 (idx 92, type 57)

tveeprom 2-0050: TV standards NTSC(M) (eeprom 0x08)

tveeprom 2-0050: second tuner model is Philips TEA5768HL FM Radio (idx 101,
type 62)

tveeprom 2-0050: audio processor is CX25843 (idx 37)

tveeprom 2-0050: decoder processor is CX25843 (idx 30)

tveeprom 2-0050: has radio, has no IR remote

ivtv1: This is the second unit of a PVR500

ivtv1: Correcting tveeprom data: no radio present on second unit

ivtv1: loaded v4l-cx2341x-enc.fw firmware (262144 bytes)

ivtv1: Encoder revision: 0x02050032

ivtv1: Allocate DMA encoder MPEG stream: 128 x 32768 buffers (4096KB total)

ivtv1: Allocate DMA encoder YUV stream: 194 x 10800 buffers (2048KB total)

ivtv1: Allocate DMA encoder VBI stream: 120 x 17472 buffers (2048KB total)

ivtv1: Allocate DMA encoder PCM audio stream: 455 x 4608 buffers (2048KB
total)

tuner 2-0061: type set to 57 (Philips FQ1236A MK4)

ivtv1: Initialized WinTV PVR 500 (unit #2), card #1

ivtv:  ==========  END INIT IVTV  ==========

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20060517/02c86653/attachment.htm 


More information about the mythtv-users mailing list