[mythtv-users] Mythstream video pixellating

Phill Edwards philledwards at gmail.com
Fri Nov 17 09:45:41 UTC 2006


I've been using MythStream for a long time and think it's excellent.
But since upgrading to MythTV 0.20 a couple of months ago I've found
that the video streams pixellate really badly. It usually happens on a
scene change - scene 1 will be fine and then the transition to scene 2
will be pretty much unwatchable, then scene 3 will be fine.

I stumbled across a debug output window tonight and it looks like I
have a codec issue (debug output below - sorry for the long post). Any
ideas what I need to do to fix this?



***mythstream: starting ABC News,
http://127.0.0.1/dummy.html?prog=broadbandnews&vidqual=hq&output=0***


***mythstream: stream stopped***


***mythstream: starting Debnam denies misleading Parliament,
mms://media3.abc.net.au/winlibrary/news/200611/20061117-debnam-pm_16_9_bband.wmv***

MPlayer dev-SVN-rUNKNOWN-4.1.1 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Celeron(R) CPU 2.40GHz
(Family: 15, Model: 3, Stepping: 3)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
Setting up LIRC support...
Playing mms://media3.abc.net.au/winlibrary/news/200611/20061117-debnam-pm_16_9_bband.wmv.
STREAM_ASF, URL:
mms://media3.abc.net.au/winlibrary/news/200611/20061117-debnam-pm_16_9_bband.wmv
Resolving media3.abc.net.au for AF_INET6...
Couldn't resolve name for AF_INET6: media3.abc.net.au
Resolving media3.abc.net.au for AF_INET...
Connecting to server media3.abc.net.au[202.6.74.109]: 1755...
Connected
unknown object
file object, packet length = 2888 (2888)
unknown object
unknown object
unknown object
unknown object
stream object, stream ID: 1
stream object, stream ID: 2
stream object, stream ID: 4
unknown object
data object
mmst packet_length = 2888
Cache size set to 256 KBytes
Cache fill:  0.00% (0 bytes)
Cache fill:  3.12% (8192 bytes)
Cache fill:  3.12% (8192 bytes)
Cache fill:  6.25% (16384 bytes)
Cache fill:  6.25% (16384 bytes)
Cache fill:  6.25% (16384 bytes)
Cache fill: 15.62% (40960 bytes)
Cache fill: 15.62% (40960 bytes)
Cache fill: 15.62% (40960 bytes)
ASF file format detected.
ID_AUDIO_ID=3
ID_AUDIO_ID=1
ID_VIDEO_ID=2
ID_VIDEO_ID=4
VIDEO:  [WMV2]  400x224  24bpp  1000.000 fps    0.0 kbps ( 0.0 kbyte/s)
Clip info:
 name: 20061117-debnam-pm
ID_CLIP_INFO_NAME0=name
ID_CLIP_INFO_VALUE0=20061117-debnam-pm
 author: News Video
ID_CLIP_INFO_NAME1=author
ID_CLIP_INFO_VALUE1=News Video
 copyright: Copyright (c) 2006 Australian Broadcasting Corp
ID_CLIP_INFO_NAME2=copyright
ID_CLIP_INFO_VALUE2=Copyright (c) 2006 Australian Broadcasting Corp
 comments: Debnam denies misleading Parliament
ID_CLIP_INFO_NAME3=comments
ID_CLIP_INFO_VALUE3=Debnam denies misleading Parliament
ID_CLIP_INFO_N=4
ID_FILENAME=mms://media3.abc.net.au/winlibrary/news/200611/20061117-debnam-pm_16_9_bband.wmv
ID_DEMUXER=asf
ID_VIDEO_FORMAT=WMV2
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=400
ID_VIDEO_HEIGHT=224
ID_VIDEO_FPS=1000.000
ID_VIDEO_ASPECT=0.0000
ID_AUDIO_FORMAT=353
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=0
ID_AUDIO_NCH=0
ID_LENGTH=126.00
==========================================================================
Opening video decoder: [dshow] DirectShow video codecs
ERROR: Could not open required DirectShow codec wmv8ds32.ax.
Win32 LoadLibrary failed to load: wmv8ds32.ax,
/usr/lib/win32/wmv8ds32.ax, /usr/local/lib/win32/wmv8ds32.ax
Warning: DS_Filter() could not open DirectShow DLL.  (DLL=wmv8ds32.ax,
r=0x8e5ec40)
Failed to create DirectShow filter
You need to upgrade/install the binary codecs package.
Go to http://www.mplayerhq.hu/dload.html
VDecoder init failed :(
Opening video decoder: [dmo] DMO video codecs
ERROR: Could not open required DirectShow codec wmvdmod.dll.
Win32 LoadLibrary failed to load: wmvdmod.dll,
/usr/lib/win32/wmvdmod.dll, /usr/local/lib/win32/wmvdmod.dll
IMediaObject ERROR: 0x879a1f6  could not open DMO DLL (0x0 : 0)
Failed to create DMO filter
You need to upgrade/install the binary codecs package.
Go to http://www.mplayerhq.hu/dload.html
VDecoder init failed :(
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffwmv2] vfm: ffmpeg (FFmpeg M$ WMV2/WMV8)
==========================================================================
ID_VIDEO_CODEC=ffwmv2
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 32000 Hz, 1 ch, s16le, 20.0 kbit/3.91% (ratio: 2500->64000)
ID_AUDIO_BITRATE=2500
ID_AUDIO_RATE=32000
ID_AUDIO_NCH=1
Selected audio codec: [ffwmav2] afm: ffmpeg (DivX audio v2 (FFmpeg))
==========================================================================
[export] Buffer size must be between 1 and 2048
[export] Exporting to file: /tmp/mplayer-af_export_mythtv
[export] Memory mapped to file: /tmp/mplayer-af_export_mythtv (0xb7c0f000)
[export] Exporting to file: /tmp/mplayer-af_export_mythtv
[export] Memory mapped to file: /tmp/mplayer-af_export_mythtv (0xb7c0f000)
alsa-init: using device default
alsa: 48000 Hz/1 channels/2 bpf/8192 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 48000Hz 1ch s16le (2 bytes per sample)
[export] Exporting to file: /tmp/mplayer-af_export_mythtv
[export] Memory mapped to file: /tmp/mplayer-af_export_mythtv (0xb7c0f000)
[export] Exporting to file: /tmp/mplayer-af_export_mythtv
[export] Memory mapped to file: /tmp/mplayer-af_export_mythtv (0xb7c0f000)
[export] Exporting to file: /tmp/mplayer-af_export_mythtv
[export] Memory mapped to file: /tmp/mplayer-af_export_mythtv (0xb7c0f000)
ID_AUDIO_CODEC=ffwmav2
Starting playback...
VDec: vo config request - 400 x 224 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [xv] 400x224 => 400x224 Planar YV12  [zoom]
X11 error: BadAccess during XSelectInput Call
X11 error: The 'ButtonPressMask' mask of specified window has probably
already used by another appication (see man XSelectInput)
X11 error: MPlayer discards mouse control (reconfiguring)
A:   3.1 V:   3.1 A-V:  0.032 ct:  0.000   1/  1 ??% ??% ??,?% 0 0 16%

***mythstream: stream playing***


Regards,
Phill


More information about the mythtv-users mailing list