[mythtv-users] MythStream/Mplayer and Real Media Codecs

Phill Edwards philledwards at gmail.com
Sat Nov 18 06:24:18 UTC 2006


> I have been having some really bad pixellation issues with some video
> streams in MythStream - so bad that it's pretty muich unwatchable.
> Fortunately the source offers Real media as well as Windows media so
> I've updated my parser to use the Real streams. But when I try to
> watch them I find that the Mplayer can't find any Real codecs. I had
> thought it would do it out of the box but obviously not. What packages
> do I need to install to get this working? I can't actually find any
> Real Player rpms for FC5.

OK, sorry - I found a RPM at the Real Player site - should have looked
there first, shouldn't I!

BUT - the problem remains. Here's the debug output from the mplayer
window in MythStream. I get the same when I run mplayer and the RTSP
stream from the command line:

***mythstream: starting 1.Bono urges Howard to increase aid,
rtsp://media1.abc.net.au/reallibrary/news/200611/20061118-bono-howard_16_9_bband.rm***

MPlayer 1.0rc1-4.1.1 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Celeron(R) CPU 2.40GHz
(Family: 15, Model: 3, Stepping: 3)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled with runtime CPU detection.
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
Playing rtsp://media1.abc.net.au/reallibrary/news/200611/20061118-bono-howard_16_9_bband.rm.
Resolving media1.abc.net.au for AF_INET6...
Couldn't resolve name for AF_INET6: media1.abc.net.au
Resolving media1.abc.net.au for AF_INET...
Connecting to server media1.abc.net.au[202.6.74.108]: 554...
Cache size set to 256 KBytes
Cache fill:  0.00% (0 bytes)
Cache fill:  3.12% (8192 bytes)
Cache fill:  6.25% (16384 bytes)
Cache fill: 12.50% (32768 bytes)
Cache fill: 15.62% (40960 bytes)
REAL file format detected.
Stream description: video/x-pn-multirate-realvideo logical stream
Stream mimetype: video/x-pn-realvideo
ID_VIDEO_ID=0
Stream description: audio/x-pn-multirate-realaudio logical stream
Stream mimetype: audio/x-pn-realaudio
ID_AUDIO_ID=1
VIDEO:  [RV30]  400x224  24bpp  25.000 fps    0.0 kbps ( 0.0 kbyte/s)
Clip info:
 name: 20061118-bono-howard
ID_CLIP_INFO_NAME0=name
ID_CLIP_INFO_VALUE0=20061118-bono-howard
 author: News Video
ID_CLIP_INFO_NAME1=author
ID_CLIP_INFO_VALUE1=News Video
 copyright: Copyright (c) 2006 Australian Broadcasting Corp
ID_CLIP_INFO_NAME2=copyright
ID_CLIP_INFO_VALUE2=Copyright (c) 2006 Australian Broadcasting Corp
ID_CLIP_INFO_N=3
ID_FILENAME=rtsp://media1.abc.net.au/reallibrary/news/200611/20061118-bono-howard_16_9_bband.rm
ID_DEMUXER=real
ID_VIDEO_FORMAT=RV30
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=400
ID_VIDEO_HEIGHT=224
ID_VIDEO_FPS=25.000
ID_VIDEO_ASPECT=0.0000
ID_AUDIO_FORMAT=cook
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=22050
ID_AUDIO_NCH=2
ID_LENGTH=63.00
==========================================================================
Opening video decoder: [realvid] RealVideo decoder
Error: /usr/lib/win32/drvc.so: cannot open shared object file: No such
file or directory
Error loading dll
ERROR: Could not open required DirectShow codec drvc.so.
Win32 LoadLibrary failed to load: drvc.so, /usr/lib/win32/drvc.so,
/usr/local/lib/win32/drvc.so
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
Error: /usr/lib/win32/drv3.so.6.0: cannot open shared object file: No
such file or directory
Error loading dll
ERROR: Could not open required DirectShow codec drv3.so.6.0.
Win32 LoadLibrary failed to load: drv3.so.6.0,
/usr/lib/win32/drv3.so.6.0, /usr/local/lib/win32/drv3.so.6.0
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
Error loading dll
ERROR: Could not open required DirectShow codec drv33260.dll.
Win32 LoadLibrary failed to load: drv33260.dll,
/usr/lib/win32/drv33260.dll, /usr/local/lib/win32/drv33260.dll
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Opening video decoder: [realvid] RealVideo decoder
Error: /usr/lib/win32/drvc.bundle/Contents/MacOS/drvc: cannot open
shared object file: No such file or directory
Error loading dll
ERROR: Could not open required DirectShow codec drvc.bundle/Contents/MacOS/drvc.
Win32 LoadLibrary failed to load: drvc.bundle/Contents/MacOS/drvc,
/usr/lib/win32/drvc.bundle/Contents/MacOS/drvc,
/usr/local/lib/win32/drvc.bundle/Contents/MacOS/drvc
Read the RealVideo section of the DOCS!
VDecoder init failed :(
Cannot find codec matching selected -vo and video format 0x30335652.
Read DOCS/HTML/en/codecs.html!
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
MPlayer interrupted by signal 11 in module: init_audio_codec
ID_SIGNAL=11
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in
DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in
your   gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We
can't and won't help unless you provide this information when
reporting a possible bug.

***mythstream: stream stopped***

Any ideas what I need to do to get mplayer to play nice?

Regards,
Phill


More information about the mythtv-users mailing list