[mythtv-users] Audio from SAA7134

Andrew Osborn aosborn at gmail.com
Sun Nov 26 16:40:09 UTC 2006


Some more work I did on this.

For the sound quality issue. I turned the master/pcm sound down to 75%
and that didn't seem to fix it. I now have to turn up my reciever even
more to hear it, and get the same amount of hiss at the new higher
level.

It also is only from the audio tuner, not from my sound card. I
haven't tested it on a DVD (I don't think this box has a dvd
player...something to add later). But on recorded TV it does have the
hissing/static.

On 11/24/06, Andrew Osborn <aosborn at gmail.com> wrote:
> Guys,
> That all worked very well. I have sound now. I am having 2 problems though.
>
> First, I only get audio from the Left channel, that was reported a few
> places but I don't know if a fix was ever given out.
>
> Second, the audio quality isn't good at all. During dead air it has a
> fairly loud hiss and during speaking/other sounds it is staticy.
> Anything to easily fix this? It isn't really usable in this condition
> because of it.
>
> Thanks for everything!
>
>
> On 11/24/06, Michael Lynch <lynchmv at gmail.com> wrote:
> > On 11/24/06, Andrew Osborn <aosborn at gmail.com> wrote:
> > > Hello All,
> > >
> > > Has anyone had problems getting an SAA7134 TV Tuner card working? Mine
> > > is not being detected as an audio device, and I'm not sure what steps
> > > I have to go through to get it in the audio device list. The card is a
> > > Compro VideoMate TV Gold Plus which uses the SAA7134 driver (I use: #
> > > modprobe saa7134 card=41 tuner=17).
> > >
> > >
> >
> > I have this exact card (I actually put up the original mythtv wiki
> > page for it) and here is my configuration
> > (http://www.mythtv.org/wiki/index.php/User:Lynchmv):
> >
> > #> lspci -v
> > 02:09.0 Multimedia controller: Philips Semiconductors SAA7133 Video
> > Broadcast Decoder (rev 10)
> >        Subsystem: Compro Technology, Inc. Compro VideoMate TV Gold+
> >        Flags: bus master, medium devsel, latency 64, IRQ 5
> >        Memory at feafe800 (32-bit, non-prefetchable) [size=2K]
> >        Capabilities: [40] Power Management version 2
> >
> > #> arecord -l
> > **** List of CAPTURE Hardware Devices ****
> > card 0: ICH5 [Intel ICH5], device 0: Intel ICH [Intel ICH5]
> >  Subdevices: 1/1
> >  Subdevice #0: subdevice #0
> > card 0: ICH5 [Intel ICH5], device 1: Intel ICH - MIC ADC [Intel ICH5 - MIC ADC]
> >  Subdevices: 1/1
> >  Subdevice #0: subdevice #0
> > card 0: ICH5 [Intel ICH5], device 2: Intel ICH - MIC2 ADC [Intel ICH5
> > - MIC2 ADC]
> >  Subdevices: 1/1
> >  Subdevice #0: subdevice #0
> > card 0: ICH5 [Intel ICH5], device 3: Intel ICH - ADC2 [Intel ICH5 - ADC2]
> >  Subdevices: 1/1
> >  Subdevice #0: subdevice #0
> > card 1: SAA7134 [SAA7134], device 0: SAA7134 PCM [SAA7134 PCM]
> >  Subdevices: 1/1
> >  Subdevice #0: subdevice #0
> >
> > RELEVANT INFO FROM /etc/modprobe.conf
> > ### Begin Capture Cards
> > alias char-major-81 videodev
> >
> > # Compro VideoMate Gold+ as video0
> > alias char-major-81-0 saa7134
> > options saa7134 card=41 tuner=17
> >
> > ### Get onboard sound to dsp0
> > alias snd-card-0 snd-intel8x0
> > options snd-card-0 index=0
> > options snd-intel8x0 index=0
> > remove snd-intel8x0 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ;
> > }; /sbin/modprobe -r .ignore-remove snd-intel8x0
> >
> > ### Get sound from Compro to dsp1
> > alias snd-card-1 saa7134-alsa
> > options snd-card-1 index=1
> > options saa7134-alsa index=1
> > remove saa7134-alsa { /usr/sbin/alsactl store 1 >/dev/null 2>&1 || : ;
> > }; /sbin/modprobe -r .ignore-remove saa7134-alsa
> >
> > RELEVANT INFO FROM /etc/rc.d/rc.local
> > ## V4L Cards
> > /usr/local/bin/v4lctl -c /dev/video0 volume mute off
> >
> > RELEVANT MythTV info (from mysql tables)
> > videodevice: /dev/v4l/video0
> > audiodevice: /dev/dsp1
> > vbidevice: /dev/v4l/vbi0
> > cardtype: V4L
> > defaultinput: Composite1 (this will be different if you're using the
> > coax, I'm capturing from an STB using RCA and line in)
> > audioratelimit: 32000
> > _______________________________________________
> > mythtv-users mailing list
> > mythtv-users at mythtv.org
> > http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> >
>
>
> --
>
> Andy Osborn
>


-- 

Andy Osborn


More information about the mythtv-users mailing list