[mythtv-users] Channels do not show on Program Guide

Aviv Eliezer aviv_eliezer at yahoo.com
Fri Sep 8 12:09:28 UTC 2006



Nick <knowledgejunkie at gmail.com> wrote:

On 07/09/06, Aviv Eliezer wrote:
>> Yes, a video source is defined on composite-0 of the pvr-150.
>> I've made sure and in "Input Connection" composite-0 points to the same
>> video source-
>> And in the "Chnnel Editor", these newly-created channels points the same
>> video source as well.
>> However, none of the channels have an "XMLTV ID". Could that be the issue?
>
>If channels do not have XMLTV IDs, mythfilldatabase can not associate
>downloaded listings with them (either when run manually or
>automatically). However, the channels should still appear in the
>program guide, just with no program information.
>
>Configuring the grabber should have added the XMLTV IDs to the
>channels. Are you able to run the grabber manually and produce a valid
>XML file containing listings? I would fix up the XMLTV IDs and see if
>this helps at all.
>
>Also, are all of your channels marked as visible?

Ok, Nick, I think I'm getting what's happening here.
After mythtv-setup, when I run 'mythfilldatabase --manual' and fill in the channel id's etc-
The channels are *not* created with valid XMLTV_ID. Beats me as to why. If I manually edit the channels and enter xmltv_id, program guide works fine. (BTW, all channels are marked visible).
Alternatively, if I delete and recerate mythconverg db, and after setting up the video source I click the "Fetch Channels from listings source" button-
Then the channels are then created with xmltv_id, but with no channel number. If I manually edit the channels and fix channel numbers, program guide works fine.
When I run the grabber manually, it looks like valid result- channel id's are valid, as well as epg data.
Do you think it's something with the grabber?

Also, another question: while using the Program Finder, since the majority of the program titles I'm seeing are in Hebrew, all of the programs are filed under the "@" character.
Is there any way to add the Hebrew Alphabet to the character list, so that I can see each program filed under it's Hebrew first letter? 

Last, do you know if there's a Hebrwe based myth-frontend translation? If not, I'd be happy to provide one, if you can direct me to the files I should change.

Thanks!!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20060908/9c72ecaa/attachment.htm 


More information about the mythtv-users mailing list