[mythtv-users] configuring xmltv_huro

Ákos Maróy darkeye at tyrell.hu
Sun Sep 10 13:49:50 UTC 2006


Stuart Morgan wrote:
> At the moment the choice of xmltv grabbers are hard-coded. It may be enough to 
> set the "xmltvgrabber" field of the videosource table to the name of the 
> grabber you want to use (location in PATH) but if the grabber requires any 
> special handling this means modifying programs/mythfilldatabase/filldata.ccp

thanks for the help. I did that, now the videsource table looks like this:

mysql> select * from videosource;
+----------+------+--------------+--------+-----------+----------+----------+--------+
| sourceid | name | xmltvgrabber | userid | freqtable | lineupid |
password | useeit |
+----------+------+--------------+--------+-----------+----------+----------+--------+
|        1 | TV   | tv_grab_huro |        | default   | NULL     | NULL
    |      0 |
+----------+------+--------------+--------+-----------+----------+----------+--------+
1 row in set (0.00 sec)


but, it doesn't seem to work, I get the following with
 mythfilldatabase --refresh-all -v all  :

2006-09-10 15:46:57.992 Updating source #1 (TV) with grabber tv_grab_huro
2006-09-10 15:46:57.992 Grabbing XMLTV data using tv_grab_huro is not
verified as working.
2006-09-10 15:46:57.992 MSqlQuery: SELECT MAX(endtime) FROM program
WHERE manualid=0;
2006-09-10 15:46:57.993 MSqlQuery: UPDATE settings SET data
='mythfilldatabase ran, but did not insert any new data into the Guide.
 This can indicate a potential grabber failure.' WHERE
value='mythfilldatabaseLastRunStatus'



Am I missing something?


Akos


More information about the mythtv-users mailing list