[mythtv-users] My Perennial Problems with XvMC

Damien Dusha damiendusha at netspace.net.au
Sun Sep 17 12:19:43 UTC 2006


In reply to:

"Some new insight:

I've hosed my FC6T3 install and have gone to FC5.  I've once again
been through all of the configurations one-by-one.  I'm currently
running mythtv and the nvidia drivers from atrpms.  XvMC, of course,
acts exactly the same as it did with FC4 and FC6T3 in both mplayer
(svn) and myth (0.20).  For a while, I had a file XvMCConfig in
/etc/X11/ that was pointing to the old location of the xvmc libraries
(the one from the nvidia installer on FC6T3).   While this file
existed, I noticed playback was exactly the same as before, but the
OSD was in color (implying xvmc wasn't working).  However, I was still
getting tearing and XvMC errors in the frontend terminal.  When I
changed the file to point to the correct libraries, the only
noticeable difference was that the OSD was now black and white.  The
poor quality of the playback remained quite similar.  Maybe this will
spark an idea in someone who knows how this all works.  To summarize:"

----

I can concur with this behavior...  I run FC5 with a NVIDA 6200 (AGP), and I noted last night that this seems to be the case.

Most certainly, the OSD is colour when I turn XvMC off, and BW when I turn it on. However, I cannot state for certain (yet, it'd be easily testable) to see if that was an 0.19 vs 0.20 (I seem to remember 0.19, though having the same stuttering problem, to have a color OSD, even without specifying the link - I think there was another thread on this recently, but I haven't read it)

I also remember seeing something on this issue in the past, though I can't remember where it was.  I'll look it up sometime this week.

However, I haven't yet had a chance to play with mplayer, but I'd like to do so before too long.  In addition, I have Ubuntu on another hdd (not currently plugged in), so it'd be interesting to see if this is a distribution issue of some sort (though it buggers me why it might be... is there any changes in confiruation in (say) the x server that might be different?  If so, I might be able to have a check)

Thoughts?  I'm trying to join some dots here, but haven't got there yet.

Cheers,
Damien.



More information about the mythtv-users mailing list