[mythtv-users] surround sound audio streams

Scott list-mythtv at bluecamel.eml.cc
Mon Sep 25 14:20:59 UTC 2006


On Sep 22, 2006, at 8:00 PM, jack snodgrass wrote:

> to be honest... I don't know... I know this.....
>
> On a HDTV Recorded mpg stream from my mythbackend...
> when I play it with VLC I get different sets of audio options
> as the stream plays.

Based on what you're saying I'm willing to bet that VLC is simply  
down mixing to your requested format. This means that when an AC3 5.1  
channel format is available VLC lets you select various options to  
remix the 5.1 audio into your preferred format (ie: mono, stereo, etc)

> When I watch CSI or NFL Football with mythtv or mythfrontend...
> I can't get the 5.1 surround sound to work... no woman behind me
> yelling at the refs telling him he's blind..... ;) I love surround  
> sound. ;)
> Scared the crap out of me the first time I watched a HDTV show with
> my speaker set up.
>
> Does that help at all explain my situation?


You stated that you're using 3 analog 1/8 stereo jacks on your sound  
card and connecting to the 6 inputs. You didn't say if you were  
hooking this up directly to your A/V receiver (sound card -> av  
receiver -> speakers) or if you were hooking this directly to your  
speakers (sound card -> speakers) but I don't think it matters.

I used to have the Audigy2 ZS working via digital spdif out the back  
of the card and connected to my A/V receiver. Same result, less  
cables :)

At this point I would suggest trouble shooting with mplayer to gather  
information about which ALSA config is being used. if you run mplayer  
-v -ao alsa mythtv_file.mpg you should see an alsa-init section along  
with AO messages that describe the sound format detected. Chances are  
something like ALSA:surround51 is being used, or could be, to make  
your setup work.

--
Scott


More information about the mythtv-users mailing list