[mythtv-users] M2NPV, nvidia/X11 settings

Mark A. O'Neil mark.a.oneil at Dartmouth.EDU
Thu Apr 5 16:41:44 UTC 2007


On Apr 5, 2007, at 10:25 AM, Steve wrote:

> Sounds like your mixing connections and display devices and making
> assumptions. You also don't mention what resolution your running via
> s-video.

Yes, I suppose I am making some assumptions.

Please let me attempt to clarify:
All the video-out and recording settings for myth and xorg.conf are  
default configs - I had made no specific changes regarding myth  
resolution or xorg setup. I am (erroneously perhaps) assuming as I am  
at work, that the default resolution for s-video is 480x480. I have  
since made changes to xorg.conf to get HD-Component to work.

Comparisons:
Using vga to a vga monitor:  display is acceptable and playback of  
recordings is good
Using s-video to my LCD TV: Everything is good if not perfect

I cannot test DVI or HDMI as I do not have those cables (and am  
reluctant to spend the cash until I exhaust other options).
I cannot test vga (or DVI, HDMI) to the projector as I do not have  
those cables.

I can and have tested s-video and HD-component to the projector:
s-video: full color - fuzzy desktop and recording playback - dvd perfect
HD-component: appears more crisp, fills the screen, but only Blue

The results on the projector are for all video - desktop as well as  
myth - hence it is my assumption (again with the assumptions!) that  
the core of the problem is with the x11 configuration, possibly  
aggravated via projector scaling.

> What I suggest is to first get 720p(1280x720) and 480i (720x480)
> output working via component to the projector (or better HDMI/DVI) as
> that should give you the best quality for the menu and SD content like
> what your PVR and DVD's play at.

I am currently, after mucking about with the xorg.conf the last few  
days, getting fair output on HD-Component at  720p (1280x720), but it  
is all Blue - so I guess it is hard to tell, but it is filling the  
screen nicely and seems more crisp - I can more easily read desktop  
text.

> Now, the menu should look crisp at either resolution (though I'd
> suggest using 720p for the menu since that is what is native for the
> projector) since Myth pre-scales the menu to the desired resolution.
> Then you can play with seeing whether you prefer Myth(Xv really) to
> scale SD content to 1280x720 or the projector doing it. I suspect the
> projector will do a better job of scaling (that's a damned good 720p
> projector), so you would want to have Myth output your PVR and DVD
> playback at 480i (you can also try 480p and let Myth do the
> deinterlacing).

I believe you are correct and in fact I recall that the Myth menus do  
seem pretty crisp and I will certainly take a look at implementing  
what you propose. Is it unreasonable of me to expect that the desktop  
video be crisp?

As for the quality of the projector I am glad to hear from a "real  
person" it is a good one. I have only had it a couple months and I  
can definitely agree - my 360 and DVDs playback fantastic.

> I feel your blurry SD is due to the inherent noise of recording over
> the PVR cards compared to the near perfectly clean DVD video,
> especially when comparing the two.

Hmm not to be argumentative but, given all video output (via s-vid)  
looks good on the LCD TV (okay as good as regular cable playback) I  
still am thinking X11 issues are the culprit on the projector and  
that the TV, which is newer production than the projector, simply  
dynamically manages the signal better(?).

> Make sure, given the size of your playback(projector, I'm assuming
> 100" screen? =D ), that you use 480x480 or 720x480, either should be
> find for SD, both have their advantages given the situation, and that
> you use a relatively high bitrate, 6000/9800 I think are good options,
> some may say overkill, but even at those levels I sometimes notice
> artifacting during fast movements (like sports).

I will confirm the resolution and bitrates and adjust accordingly.

However, I think we /may/ be talking about two different yet very  
related issues:
1) getting xorg.conf set to correctly display all colors at optimal  
resolution for the projector and
2) getting optimal performance out of MythTV in conjunction with the  
projector

I am again assuming that #1 is an X11 issue and #2 is a MythTV  
configuration issue.

> heed the signature!
> http://www.mythtv.org/wiki/index.php/Modeline_Database#Panasonic_PT- 
> AE900U_Projector

Absolutely! And I think I had already been there before I posted my  
request for suggestions as that set of instructions did not work for  
me and to be honest the learning curve for custom configs for X,  
using what are in some cases undocumented options, is a bit steep. ;-)

Thanks for your continued thoughts I am very appreciative.

-m

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070405/fc226959/attachment.htm 


More information about the mythtv-users mailing list