[mythtv-users] upgraded to fedora 7, now firewire is broken

Mike LaPlante mike at dividia.net
Thu Aug 9 13:50:21 UTC 2007



Gabe Rubin wrote:
> I can't seem to load the firewire driver since upgrading to fedora 7.
> I think there is some issue with the kernel, because it was working
> until I was successful at upgrading the kernel from a fc5 to a fc7
> version.
>
> Plugreport gives me this result:
> [mythtv at localhost ~]$ plugreport
> raw1394 - couldn't get handle: No such device or address
> This error usually means that the raw1394 driver is not loaded or that
> /dev/raw1394 does not exist.
>
> But I do have /dev/raw1394:
> # ls /dev/raw1394
> /dev/raw1394
>
> I am running 2.6.22.1-41.fc7
>
> and when I try to modprobe raw1394:
> FATAL: Module raw1394 not found.
>
>
> The interesting bits from lsmod:
> firewire_ohci          20673  0
> firewire_core          43137  1 firewire_ohci
>
> I also see this in dmesg:
> firewire_core: created new fw device fw1 (0 config rom retries)
> firewire_core: phy config: card 0, new root=ffc1, gap_count=5
>
>
> Is there something new with fedora 7?  How should I properly load the
> firewire driver?
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
>   
Fedora 7 has a brand new firewire stack the old modules are not built by 
default. I had to manually compile them which was sort of a pain. Here's 
a thread that may be helpful.
http://forums.fedoraforum.org/showthread.php?t=157524

There is an ezplanet repo that supplies fedora kernels with the old 
firewire modules built, however, you can't really use that kernel and 
ATrpms nvidia, ivtv, lirc, etc kmdl packages.

Mike


More information about the mythtv-users mailing list