[mythtv-users] Faster motions in recordings are flickering on the TV

George Mari george_mythusers at mari1938.org
Tue Aug 14 13:51:08 UTC 2007


Ma Begaj wrote:
> Hi,
> 
> When I watch a recording, the picture is flickering when the actors
> are running or when a ticker is moving on the screen.
> 
> I would not call this flickering, but I can see that the picture is
> not clear. Every faster moves on the screen cause this. When I watch
> the recording in mplayer, the problem is not visible.
> 
> I think (not sure at the moment, because I am not at home) that the
> same problem is visible when watching LiveTv. I have pvr150 and I am
> using libmpeg2 for decoding without any filters
> 
> This problem does not occur when I watch my movies using mplayer.
> Computer is connected with a TV through (4 meters long) S-Video cable
> (PAL). TV resolution is 800x600.
> 
> I am not sure where to search for a solution and I would appreciate
> any advice. I tried to play around with libmpeg2/ffmpeg/xvmc but I did
> not come pretty far with that.
> 
> Thanks a lot.
> 
> M.
> 
Have you tried turning deinterlacing on?  Any of the different 
deinterlace algorithms?

 From the main menu, choose Utilities/Setup->Setup->Tv Settings->Playback

On the first screen, at the top, the first two items are a checkbox for 
"Deinterlace playback" and next to a list of different deinterlace 
algorithms.

Personally, I find the "Bob (2x framerate)" setting provides the most 
lifelike playback on standard definition TV.  I get playback 
indistinguishable from my settop box using this, and no custom filters.


More information about the mythtv-users mailing list