[mythtv-users] Problems Compiling Mythplugins from SVN

Joe Ripley vitaminjoe at gmail.com
Tue Aug 14 14:53:44 UTC 2007


On 8/14/07, Ian Barton <lists at manor-farm.org> wrote:
> I am using Kubuntu Feisty and have checked out, compiled and installed
> the current svn version of MythTV.
>
> However, I am having problems compiling the plugins. My ./configure
> options are:
>
> ./configure --disable-mythweather --disable-mythmusic --disable-mythgame
> --disable-mythphone --disable-mythflix
>
> When I run make I get the following errors:
>
> /usr/include/qt3/qsqldatabase.h:63: warning: 'class
> QSqlDriverCreatorBase' has virtual functions but non-virtual destructor
> ccache g++  -o mytharchivehelper main.o archiveutil.o
> -L/usr/share/qt3/lib -L/usr/X11R6/lib -L/usr/local/lib -lfreetype
> -lmp3lame -lasound -L/usr/lib -lartsc -lgmodule-2.0 -ldl -lgthread-2.0
> -lrt -lglib-2.0 -ljack -lraw1394 -liec61883 -lavc1394 -lrom1394
> -L/usr/X11R6/lib -lXinerama -lXv -lXxf86vm -lmyth-0.20 -lmythtv-0.20
> -lmythui-0.20 -lmythfreemheg-0.20 -lmythlivemedia-0.20 -lqt-mt -lGLU
> -lGL -lXmu -lXext -lX11 -lm -lpthread
> /usr/bin/../lib/libmythavcodec-0.20.so.0: undefined reference to
> `XvMCFlushSurface'
> /usr/bin/../lib/libmythavcodec-0.20.so.0: undefined reference to
> `XvMCLoadQMatrix'
> /usr/local/lib/libmythtv-0.20.so: undefined reference to
> `ff_ac3_parse_header'
> /usr/bin/../lib/libmythavcodec-0.20.so.0: undefined reference to
> `XvMCSyncSurface'
> /usr/bin/../lib/libmythavcodec-0.20.so.0: undefined reference to
> `XvMCBeginSurface'
> collect2: ld returned 1 exit status
> make[2]: *** [mytharchivehelper] Error 1
>
> I guess that he latest svn has some dependencies that aren't present in
> the 0.20 version. Anyone got any ideas what I am missing?

It looks like the libmythavcodec-0.20.so.0 file is calling XvMC
functions but libXvMC isn't linked.  You might need a '-lXvMC'
somewhere in your g++ command line.  I'm guessing that 'configure'
should handle this for you, so I'm not sure what went wrong.  Does
configure give you any weird output when you run it prior to making?


-- 
Joe Ripley
vitaminjoe at gmail.com


More information about the mythtv-users mailing list