[mythtv-users] MythWeather in 0.20.2/-fixes packages (was Re: Mythweather-revamp and 0.20.2 release)

Michael T. Dean mtdean at thirdcontact.com
Sun Aug 26 12:24:31 UTC 2007


On 08/25/2007 11:02 PM, Harry Devine wrote:
> I just did a "yum update mythtv" to update to the latest RPM updates
> for 0.20.2.  I had, about 2 weeks ago, checked out and built the
> latest mythweather-revamp code and it was working fine.  Now, when I
> run MythWeather, I get the following error message:
>  
> "The mythweather plugin was compiled, against libmyth version:
> 0.20.20060828-4, but the installed libmyth is at version:
> 0.20.20070821-1.  You probably want to recompile the mythweather
> plugin after doing a make distclean."
>  
> I have done this and keep getting this message.  Any ideas on what I'm
> missing here?

MythWeather is not included in 0.20.2 (or latest -fixes), since it's
broken.  If you want to install MythWeather's latest trunk (and backport
it to work with 0.20.2/-fixes), feel free to do so, but you'll need to
compile it against your current libs.  Your packages won't install it
for you until 0.21 is released (assuming people actually work on/submit
patches for the new trunk MythWeather before 0.21).

Axel, would it be appropriate for your RPM scripts to delete
/usr/{,local/}lib/mythtv/plugins/libmythweather.so ?  Even if the user
had a -revamp version working, it won't work with the new libs.  (I'm
assuming this was on an FC system, but if not, perhaps someone should
talk to the packager involved for this distro.)

See http://www.gossamer-threads.com/lists/mythtv/commits/285316#285316

Mike


More information about the mythtv-users mailing list