[mythtv-users] Problems Upgrading Linux/MythTV (ivtv-fb and PVR-350 on fc6)

Jacob Steenhagen jacob at steenhagen.us
Mon Aug 27 00:37:37 UTC 2007


With the impending Zap2it shutdown and transition to Schedules Direct, I
figured it was time to finally update my MythTV box. I had been running on
Fedora Core 4. I had issues when I tried to jump to Fedora 7, so I ended up
going to Fedora Core 6.

I've worked through most of the issues that I've had, but there's one I
can't seem to get through. When I first installed this, I used Jarod's guide
with only slight deviations. The error I'm currently getting is when I try
to startx:

=== Start Paste ===
xauth:  creating new authority file /root/.serverauth.3552


X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.9-55.ELsmp i686 Red Hat, Inc.
Current Operating System: Linux mythtv.steenhagen.us 2.6.22.2-42.fc6 #1 SMP
Wed Aug 15 12:34:26 EDT 2007 i686
Build Date: 18 June 2007
Build ID: xorg-x11-server 1.1.1-47.10.fc6
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Aug 26 20:23:27 2007
(==) Using config file: "/etc/X11/xorg.conf"
(EE) ivtvHWProvbe failed to do IVTVFB_IOCTL_GET_STATE for device /dev/fb1
(EE) Screen 0 deleted because of no matching config section.
(EE) Device(s) detected, but none match those in the config file.

Fatal server error:
no screens found
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.

=== End Paste ===

I just can't seem to get past this.... so here's a few things in my install
that may be relevant.

[root at mythtv ~]# rpm -qa | grep ivtv
ivtv-kmdl-2.6.22.2-42.fc6-1.0.2-134.fc6
perl-Video-ivtv-0.13-8.fc6.at
ivtv-firmware-20070217-13.at
ivtv_xdriver-0.10.7-8_r3843.fc6.at
ivtv-1.0.2-134.fc6


Aug 26 20:17:14 mythtv kernel: ivtv:  ==================== START INIT IVTV
====================
Aug 26 20:17:14 mythtv kernel: ivtv:  version 1.0.0 (2.6.22.2-42.fc6 SMP
mod_unload 686 4KSTACKS ) loading
Aug 26 20:17:14 mythtv kernel: ivtv0: Autodetected Hauppauge card (cx23415
based)
Aug 26 20:17:14 mythtv kernel: ACPI: PCI Interrupt Link [LNKA] enabled at
IRQ 11
Aug 26 20:17:14 mythtv kernel: ACPI: PCI Interrupt 0000:00:0d.0[A] -> Link
[LNKA] -> GSI 11 (level, low) -> IRQ 11
Aug 26 20:17:14 mythtv kernel: ivtv0: loaded v4l-cx2341x-enc.fw firmware
(3747975632 bytes)
Aug 26 20:17:14 mythtv kernel: ivtv0: loaded v4l-cx2341x-dec.fw firmware
(3747975640 bytes)
Aug 26 20:17:14 mythtv kernel: ivtv0: Encoder revision: 0x02060039
Aug 26 20:17:14 mythtv kernel: ivtv0: Decoder revision: 0x02020023
Aug 26 20:17:14 mythtv kernel: tveeprom 1-0050: Hauppauge model 48132, rev
K268, serial# 8083337
Aug 26 20:17:14 mythtv kernel: tveeprom 1-0050: tuner model is LG TAPE H001F
MK3 (idx 68, type 47)
Aug 26 20:17:14 mythtv kernel: tveeprom 1-0050: TV standards NTSC(M) (eeprom
0x08)
Aug 26 20:17:14 mythtv kernel: tveeprom 1-0050: audio processor is MSP4448
(idx 27)
Aug 26 20:17:14 mythtv kernel: tveeprom 1-0050: decoder processor is SAA7115
(idx 19)
Aug 26 20:17:14 mythtv kernel: tveeprom 1-0050: has radio, has IR receiver,
has no IR transmitter
Aug 26 20:17:14 mythtv kernel: ivtv0: Autodetected Hauppauge WinTV PVR-350
Aug 26 20:17:14 mythtv kernel: tuner 1-0043: chip found @ 0x86 (ivtv i2c
driver #0)
Aug 26 20:17:14 mythtv kernel: tda9887 1-0043: tda988[5/6/7] found @ 0x43
(tuner)
Aug 26 20:17:14 mythtv kernel: tuner 1-0061: chip found @ 0xc2 (ivtv i2c
driver #0)
Aug 26 20:17:14 mythtv kernel: saa7115 1-0021: saa7115 found
(1f7115d0e100000) @ 0x42 (ivtv i2c driver #0)
Aug 26 20:17:14 mythtv kernel: saa7127 1-0044: saa7129 found @ 0x88 (ivtv
i2c driver #0)
Aug 26 20:17:14 mythtv kernel: msp3400 1-0040: MSP4448G-A2 found @ 0x80
(ivtv i2c driver #0)
Aug 26 20:17:14 mythtv kernel: msp3400 1-0040: MSP4448G-A2 supports radio,
mode is autodetect and autoselect
Aug 26 20:17:14 mythtv kernel: tuner 1-0061: type set to 47 (LG NTSC (TAPE
series))
Aug 26 20:17:14 mythtv kernel: ivtv0: Registered device video0 for encoder
MPEG (4 MB)
Aug 26 20:17:14 mythtv kernel: ivtv0: Registered device video32 for encoder
YUV (2 MB)
Aug 26 20:17:14 mythtv kernel: ivtv0: Registered device vbi0 for encoder VBI
(1 MB)
Aug 26 20:17:14 mythtv kernel: ivtv0: Registered device video24 for encoder
PCM audio (1 MB)
Aug 26 20:17:14 mythtv kernel: ivtv0: Registered device radio0 for encoder
radio
Aug 26 20:17:14 mythtv kernel: ivtv0: Registered device video16 for decoder
MPEG (1 MB)
Aug 26 20:17:14 mythtv kernel: ivtv0: Registered device vbi8 for decoder VBI
(1 MB)
Aug 26 20:17:14 mythtv kernel: ivtv0: Registered device vbi16 for decoder
VOUT
Aug 26 20:17:14 mythtv kernel: ivtv0: Registered device video48 for decoder
YUV (1 MB)
Aug 26 20:17:14 mythtv kernel: ivtv0: loaded v4l-cx2341x-init.mpg firmware
(3747977320 bytes)
Aug 26 20:17:14 mythtv kernel: ivtv0: Initialized Hauppauge WinTV PVR-350,
card #0
Aug 26 20:17:14 mythtv kernel: ACPI: PCI Interrupt Link [LNKC] enabled at
IRQ 10
Aug 26 20:17:14 mythtv kernel: ACPI: PCI Interrupt 0000:00:11.0[A] -> Link
[LNKC] -> GSI 10 (level, low) -> IRQ 10
Aug 26 20:17:14 mythtv kernel: ivtv:  ====================  END INIT IVTV
====================


[root at mythtv ~]# grep 'fb.' /var/log/messages
Aug 26 20:17:14 mythtv kernel: vesafb: framebuffer at 0xf8000000, mapped to
0xe0880000, using 3072k, total 16384k
Aug 26 20:17:14 mythtv kernel: vesafb: mode is 1024x768x16, linelength=2048,
pages=9
Aug 26 20:17:14 mythtv kernel: vesafb: protected mode interface info at
c000:49a4
Aug 26 20:17:14 mythtv kernel: vesafb: pmi: set display start = c00c4a12,
set palette = c00c4a4c
Aug 26 20:17:14 mythtv kernel: vesafb: pmi: ports = 9010 9016 9054 9038 903c
905c 9000 9004 90b0 90b2 90b4
Aug 26 20:17:14 mythtv kernel: vesafb: scrolling: redraw
Aug 26 20:17:14 mythtv kernel: vesafb: Truecolor: size=0:5:6:5,
shift=0:11:5:0
Aug 26 20:17:14 mythtv kernel: fb0: VESA VGA frame buffer device
Aug 26 20:17:14 mythtv kernel: ivtv_fb: no version for "struct_module"
found: kernel tainted.
Aug 26 20:17:14 mythtv kernel: ivtv0-fb: Framebuffer at 0xf5510000, mapped
to 0xe1a90000, size 1665k
Aug 26 20:17:14 mythtv kernel: ivtv0-fb: === Validated display mode  ===
Aug 26 20:17:14 mythtv kernel: ivtv0-fb: Display size 640x400 (640x400
Virtual) @ 8bpp
Aug 26 20:17:14 mythtv kernel: ivtv0-fb: Display position 41,41
Aug 26 20:17:14 mythtv kernel: ivtv0-fb: Display filter : on
Aug 26 20:17:14 mythtv kernel: ivtv0-fb: Color space : RGB
Aug 26 20:17:14 mythtv kernel: ivtv0-fb: === Display mode change ===
Aug 26 20:17:14 mythtv kernel: ivtv0-fb: Display size 640x400 (640x400
Virtual) @ 8bpp
Aug 26 20:17:14 mythtv kernel: ivtv0-fb: Display position 41,41
Aug 26 20:17:14 mythtv kernel: ivtv0-fb: Display filter : on
Aug 26 20:17:14 mythtv kernel: ivtv0-fb: Color space : RGB
Aug 26 20:17:14 mythtv kernel: ivtv0-fb: Framebuffer registered on ivtv card
id 0



If anyone has any brilliant ideas how to get the frame buffer working again
on my PVR-350, I'd really appreciate it.


-- 
http://jacob.steenhagen.us
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070826/5c4231c2/attachment-0001.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: xorg.conf
Type: application/octet-stream
Size: 4147 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20070826/5c4231c2/attachment-0001.obj 


More information about the mythtv-users mailing list