[mythtv-users] MythPlugins from source problem

David Watkins watkinshome at gmail.com
Wed Aug 29 11:36:08 UTC 2007


On 29/08/2007, Joe Borne <joe.borne at gmail.com> wrote:
>
>
> > Brad DerManouelian wrote:
> > > On Aug 28, 2007, at 8:05 AM, Joe Borne wrote:
> > >
> > >> I'm attempting to go to the SVN version of MythTV on my Fed Core 6
> > >> box. I have successfully compiled mythtv, but the plugins won't
> compile.
> > >>
> > >> Running "svn st
> http://svn.mythtv.org/svn/trunk/mythplugins" gives the
> > >> message that the current version is not a working copy.
> > >>
> > >> I followed the compile and install from svn instructions on the wiki,
> > >> so I'm thinking maybe I cam grabbing from the wrong source tree maybe?
> > >>
> > >> I'd really like to go to SVN in order to get SD and several other
> > >> improvements.
> > >>
> > >> Can anyone help? Perhaps a nice little HOWTO from someone who's done
> > >> it, on getting SVN installed in order to use SD would be nice.
> > >
> > > You need to install mythtv (not just compile) before trying to compile
> > > the plugins. Did you do that first?
> > >
> >
> > "svn st http://svn.mythtv.org/svn/trunk/mythplugins" does
> not check out
> > the code, it checks the status.
> >
> > You need 'svn co  http:........mythtv' and the same for mythplugins and
> > myththemes.
> >
> > Then cd mythtv, run configure, then make, then make install. Do all that
> > before attempting to make plugins or themes.
> >
> > The previously required step 'qmake mythtv.pro' has been added as the
> > last line of configure.
> >
> > Complete scripts to do this are given at the bottom of the wiki page
> > Installing Mythtv SVN on Fedora Core (in Howto). The scripts will work
> > on basically any distribution. Other sections, such as auto-starting
> > mythbackend are fedora specific.
> >
> > Geoff
>
>
> Actually, that is the frustrating thing. After the first suggestion that I
> install mythtv first before configuring and making mythplugins, I did so.
> The error I posted was after that.
>
> So I did a clean configure/qmake/make/make install of mythtv and I did the
> same for myththemes. I then ran configure, qmake and make for mythplugins. I
> am still getting the "/usr/bin/ld: cannot find -lmyth-0.20.1 " error. A find
> for "*lmyth-0.20.1*" turns up nothing.
>
> I have noticed that qmake is nowhere to be found on my system and the qmake
> command returns no feedback. I was assuming that perhaps it's simply a
> function of the qt suite, but perhaps therein lies the problem. Searches for
> how to install qmake have turned up very little in google.
>
> Any ideas?

to see what's available try

yum list qt*

I think you're looking for three packages.  On my system,

qt
qt-devel
qt-MySQL

(you don't want qt4 (for mythtv at any rate))

so try and install with

yum install qt

etc

Once you've installed them then log out and log back in again to make
sure the QTLIB and path environment variables get updated.

Good luck


More information about the mythtv-users mailing list