[mythtv-users] MythPlugins from source problem

jack snodgrass mrlinuxgroups at gmail.com
Thu Aug 30 19:45:57 UTC 2007


On 8/30/07, Ian Hodgson <ian.hodgson at dsl.pipex.com> wrote:
> I have encountered some problems which seem very similar to the original
> post. Firstly, I have installed MythTV and had it working for a few weeks.
> As part of the installation, I picked up the PlugIns package with all the
> plugins.
>
> Now, as I do not use all of the plugins and with Myth stable and working, it
> seemed like a good idea to rebuild with only the plugins that I need. So I
> followed the instructions in the manual and ended up with the linker failing
> to find with "-lmyth-0.20.2".
>
> Having read through the thread, I can confirm that I have the Myth libraries
> in /usr/lib...
>
> libmyth-0.20.so
> libmyth-0.20.so.0
> libmyth-0.20.so.0.20
> libmyth-0.20.so.0.20.0
> ...etc...
>
> I therefore edited /etc/ld.so.conf to put /usr/lib on the linker search
> path. "ldconfig -p | grep myth" would seem to show that it is working as I
> have among other libraries, 'libmythtv-0.20.so' & 'libmythtv-0.20.so.0'
> listed.
>
> Nevertheless, a 'make' of the plugins still returns an error...
> "/usr/bin/ld: cannot find -lmyth-0.20.2"
>
> I think that all the pieces are in place, but it would seem that the linker
> is looking for a different library to the one that I have. Just for 'fun', I
> tried editing the Makefile in /mythdvd/mtd and changed the "-lmyth-0.20.2"
> to "-lmythtv-0.20" and the link succeeded with 'lmythtv', but of course
> failed on the next library.
>
> Any ideas on how to resolve this would be very much appreciated.
>
> Regards,
> Ian.
>

you can't mix and match versions... the mythtv stuff you installed is for
0.20.0 and the plugins are 0.20.2... you need the plugins for 0.20.0 or
install the 0.20.2 mythtv level to go with your 0.20.2 plugins.

jack


More information about the mythtv-users mailing list