[mythtv-users] Working too fast?

Bruce Markey bjm at lvcm.com
Fri Aug 31 21:18:59 UTC 2007


Craig Huff wrote:
> I got data that looks bad in the mythfilldatabase log file after my
> first attempt with the SchedulesDirect grabber.
> 
> Here's what I did:
> Created an account at the SchedulesDirect website,
> paid with PayPal,
> created a lineup to match my old Zap2It one,
> logged out of Schedulesdirect,
> logged back in to make sure I had the username and password straight,
>  logged out again,
> shutdown mythbackend with "#service mythbackend stop",
> ran mysqldump to backup the database,
> ran mythtv-setup per the instructions,

Textbook to this point... Good job!

> NOTE: This was a little confusing because I expected to see the
> Zap2It grabber still listed so I wasn't sure I was getting the right
> grabber until I checked the whole list.  Then when I tried to
> "Retrieve Lineups", I got no lineup data.  I had to get out of the

This is where you ran aground. First, make sure you are actually
running mythtv-setuop for version 0.20.2 or SVN HEAD.

- When you select your first existing video source, it still
has the login info for zap2it. It retrieves the zap2it lineups
and stuffs then into the lineup widget. These will be wrong for
SD.

- For "Listings grabber" select "North America (Schedules Direct)"
If this is not in the list then you are not running the correct
version of mythtv-setup (!).

- One this grabber choice has been selected, enter your SD "User
ID" (email address) and password.

- Now that it has the login info for SD, click "Retrieve Lineups".

- It should replace the zap2it choices with the lineups that you
created on the SD web page.

- Select the correct lineup and Finish.

> Video Sources window and re-enter it before I saw a lineup name.
> This was another point of confusion, so I went back to
> SchedulesDirect to see if I could match it up with a name of the
> lineup I just created, but I couldn't find a name for the lineup in
> the web page, so maybe that is my problem ;-( exited mythtv-setup
> completely,

> NOTE 2: According to the directions in the HOWTO, paragraph 24.3 I
> was supposed to then run mythfilldatabase, which I did, but it wants
> to talk to the backend when it's done.  Maybe mythbackend should have
> been started before running mythfilldatabase?  In any case, it waited

No, as noted elsewhere this tries to rerun the schedule from
scratch if the master is running. If not, the schedule is re-run
when the master starts.

===============================================================
| Attempting to contact the master backend for rescheduling.  |
| If the master is not running, rescheduling will happen when |
| the master backend is restarted.                            |
===============================================================


> for 120 seconds before trying again, (I think I must have set that
> delay somewhere in the settings, myself) and I was able to open
> another terminal window and fire up mythbackend before
> mythfilldatabase squawked anymore. and ran mythfilldatabase.

> --13:27:58--
> http://datadirect.webservices.zap2it.com/tvlistings/xtvdService 
> Resolving datadirect.webservices.zap2it.com... 206.18.98.160

"Wul, thar's you problem" =).

Resolving webservices.schedulesdirect.tmsdatadirect.com... 206.18.98.175

The zap2it server was being contacted but most likely with your
now SD user info.

Make sure you are running 0.20.2 or SVN. Choose the "North America
(Schedules Direct)" grabber. enter your SD login info and retrieve
your SD lineups then select your SD lineup. Run mfdb and you should
be good to go.

--  bjm



More information about the mythtv-users mailing list