[mythtv-users] Getting mythfilldatabase error

Nick Morrott knowledgejunkie at gmail.com
Fri Feb 23 02:01:49 UTC 2007


On 22/02/07, Sreeram Kumar <Sreeramkumar at yahoo.com> wrote:
> Hi,
>   My mythfilldatabase doesnt run automatically. when I
> checked the log I am seeing the following error. I am
> able to run it manually though. Also, I see the
> videosource as a table in the database when i do
> select tables; I have a cron job "01 10 * * * sleep
> $(expr $RANDOM \% 14400) && mythfilldatabase >
> /var/log/mythtv/mythfilldatabase.log 2>&1
> "
>
> Thanks,
> Sreeram
>
> 2007-01-27 22:14:54.256 Using runtime prefix = /usr
> 2007-01-27 22:14:54.274 New DB connection, total: 1
> 2007-01-27 22:14:54.280 Connected to database
> 'mythconverg' at host: localhost
> 2007-01-27 22:14:54.284 DB Error (loading channel
> sources):
> Query was:
> SELECT
> sourceid,name,xmltvgrabber,userid,password,lineupid
> FROM videosource  ORDER BY sourceid;
> Driver error was [2/1146]:
> QMYSQL3: Unable to execute query
> Database error was:
> Table 'mythconverg.videosource' doesn't exist

If you connect manually to the mythconverg database and run the query
below manually, what output do you get?

mysql> SELECT sourceid,name,xmltvgrabber,userid,password,lineupid FROM
videosource  ORDER BY sourceid;

If you still see an error, I would delete all videosources in
mythtv-setup, then re-create them and reconfigure your grabber from
within mythfilldatabase.

Nick
-- 
MythTV Official wiki:
http://mythtv.org/wiki/
MythTV users list archive:
http://www.gossamer-threads.com/lists/mythtv/users

"An investment in knowledge always pays the best interest." - Benjamin Franklin


More information about the mythtv-users mailing list