[mythtv-users] Mythwelcome says it cannot connect to backend... but it still works

Steve Kerrison steve at stevekerrison.com
Fri Jan 12 09:33:57 UTC 2007


Hi everyone,

I am running mythtv 0.20 on Ubuntu Edgy Eft. I've implemented 
shutdown/wakeup using /proc/acpi/alarm. As such I need mythwelcome to 
ensure the backend idles and shuts the system down after x seconds.

Mythwelcome is configured to launch at startup (under 'sessions' options 
in Gnome, with gdm set to autologin the mythtv user at startup too). 
However, I'm met with an error stating that it cannot connect to the 
backend. If I dismiss this error, of indeed leave it on display, the 
system will still shut down. Mythwelcome will, after dismissing the 
error, eventually show some of the information it should, but not 
display the next scheduled recording.

If I restart mythwelcome it shows everything it should. If I dismiss the 
connection error and launch mythfrontend from within mythwelcome, it 
works fine. If I configure mythfrontend to run at startup instead of 
mythwelcome, it works fine... but obviously never goes idle and so 
doesn't shut down.

I'm not sure where to look for the cause of/solution to this problem. 
Any suggestions please?

Cheers,
Steve Kerrison
mythtv [the at sign] stevekerrison [the dot] com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070112/4976f70b/attachment.htm 


More information about the mythtv-users mailing list