[mythtv-users] Myth incorrectly re-recording previously shown programs

Nick Morrott knowledgejunkie at gmail.com
Tue Jun 19 22:58:56 UTC 2007

On 19/06/07, Enigma <enigma at thedonnerparty.com> wrote:
> Greetings.  I have been having a problem with my Myth box for a little
> while now.  There are several shows (or maybe all shows) for which it is
> recording episodes that it previously recorded.  The episode information
> is complete, it is not a problem with missing subtitle info or anything
> like that.
> For example, I have "Deadliest Catch" set to record on Discovery.  The
> episode "Pain and Paybacks" is scheduled to record today at 1:00.  The
> recording is set to record any time on Discovery, check all recordings
> for duplicates and to use subtitle and description duplicate matching.
> The episode is scheduled to record, even though there are 3 entries in
> the oldrecorded table that have an identical subtitle, description,
> episode number and series number.  It seems like it is not checking the
> oldrecorded table, even for schedules that specifically set it.  I tried
> deleting and completely re-adding that schedule, but it still has the
> same behavior (as do several other schedules).

What type of recording rule are you using? Is it a channel record or
an all record? Is the callsign for Discovery the same now as it was
when the 3 old recordings were made? If it is currently a channel
record rule and you change it to an all record, does this change

One suggestion is to use the 'Forget Old' option in the Previous
Recordings listing and forget the 3 old episodes of Deadliest Catch
which exist in the oldrecorded table, then mark the first upcoming
showing as Never Record, and see whether the scheduler correctly uses
the new information to not record future showings.

If you change duplicate matching to Subtitle or Subtitle then
Description, does this help? I've seen similar oddities over the past
few years which this has solved, even though I could see no reason why
the dupe detection was failing, but so far haven't looked into it

Another suggestion is to paste the 3 records from `oldrecorded` (using
\G for improved layout) and the record rule from `record` (again with
\G) in case there's a more obvious reason for this behaviour.

I suppose

# mythbackend --printsched |fgrep "Deadliest"

might also be of some use.


MythTV Official wiki:
MythTV users list archive:

"An investment in knowledge always pays the best interest." - Benjamin Franklin

More information about the mythtv-users mailing list