[mythtv-users] "Parser not found for Codec Id" error message

D. Hugh Redelmeier hugh at mimosa.com
Thu Mar 1 20:00:49 UTC 2007


| From: JCA <1.41421 at gmail.com>
| Date: Sun, 28 Jan 2007 17:48:01 -0800

I've seen no reply to this, so I thought I'd reply even though it is a 
month later.  Since it has been so long since the original message, I will 
quote it in full.

|     Anybody know what the following error message
| 
| [mpeg @ 0xb740eb20]Parser not found for Codec Id: 94210 !
| 
| is all about? It is printed out by mythbackend every time a recording
| has been completed, and does not seem to have any bearing on the
| recording itself, which is perfectly fine. Actually, the mythbackend
| diagnostic lines immediately following the one above read
| 
| 0: start_time: 0.036 duration: 161.486
| 1: start_time: 61.430 duration: 161.535
| 2: start_time: 0.026 duration: 161.451
| stream: start_time: 0.289 duration: 2477.102 bitrate=3642 kb/s
| 2007-01-28 14:30:16.671 AFD: Opened codec 0x815d580, id(MPEG2VIDEO) type(Video)
| 2007-01-28 14:30:16.671 AFD: Opened codec 0x81eba70, id(MP2) type(Audio)
| 
| which I guess justify why the recording is fine. Still, I would like
| to learn what the story is with codec 94210.

I get this message too.  Google mostly shows other logs with the same
message and no discussion.

I did find this:
  http://cvs.mythtv.org/trac/ticket/158
Comment 6 says:
    It doesn't look like libavcodec/libavformat knows about Codec Id
    94210. The only stream types it supports are MPEG2-video,
    MPEG2-audio, AC3-audio. Codec 94210 looks like an DVD subtitle
    stream. This should be silently dropped. Which it looks like it
    is. It is failing in writing the output header. I don't know why
    that would be the case. Do you have write permission for the file?

I wonder where there is documentation for 94210.


More information about the mythtv-users mailing list