[mythtv-users] Myth upgrade 0.19->0.20 and MySQL upgrade 4.1->5.0 ?

Brian Wood beww at beww.org
Fri Mar 2 20:09:34 UTC 2007


On Mar 2, 2007, at 12:37 PM, David Brodbeck wrote:

> Brian Wood wrote:
>> Of course you may have to upgrade sometime. Your best bet might be to
>> copy off any recordings you want to save and start from scratch,
>> that's generally a more reliable answer for almost any type of
>> software upgrade.
>
> Failing that, a trick I've sometimes used as a sysadmin is to  
> configure
> a spare system exactly like the one I'll be upgrading, then do an
> upgrade on the spare to find any gotchas.  The trick is making sure  
> the
> spare system does, in fact, have an identical software configuration;
> this is where the notes you made while setting up the original system
> come in handy.  (You did make notes, right?) ;)

That's exactly what I'm doing now. I have a 0.19 system that's been  
running for almost a year. I set up a second box running 0.20 and I'm  
checking it out to see if there are any problems before I switch over.

I hesitated to suggest this method though, as it requires not only a  
complete spare machine with RAM, drives, CPU, mobo, video card etc.  
but also spare capture devices. Not everyone has piles of old  
hardware just sitting around.

It also doubles the load I'm putting on DataDirect. I'm not sure if  
that bothers them or not, I never have understood their business  
model. Obviously I could dope out a way to just connect to the DB in  
my live machine but the upgrade in MySQL etc. is part of the total  
upgrade and it's just easier to set up a complete spare.

This is really just to protect me against the inevitable failure of  
the 0.19 system, so far I haven't found anything in 0.20 that would  
cause me to upgrade - some "nice" features but nothing to be worth  
the bother to upgrade unless I have to, others may feel differently  
of course.


More information about the mythtv-users mailing list